Sicily 13290 Play with Strings powered by wangbin

13290. Play with Strings

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Given a string X, you can swap any two characters in X as many times as you want. You wonder whether it is possible to turn X into another string Y.

Input

The input consists of two lines. The first line is X, and the second line is YX and Y only contain lower-case letters. No strings contain more than 100 letters.

Output

For each test case, output “YES” if you can turn X into Y; otherwise, output “NO”.

Sample Input

abceecba

Sample Output

YES
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main(){
	string s1,s2;
	cin>>s1;
	cin>>s2;
	int sum1=0,sum2=0;
	int len1=s1.size();
	int len2=s2.size();
	for(int i=0; i<=len1; i++){
		sum1+=s1[i]; 
	}
	for(int i=0; i<=len2; i++){
		sum2+=s2[i]; 
	}
	if(sum1==sum2)
		cout<<"YES"<<endl;
	else 
		cout<<"NO"<<endl;
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值