Sicily 13290. Play with Strings

13290. Play with Strings

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Given a string X, you can swap any two characters in X as many times as you want. You wonder whether it is possible to turn X into another string Y.

Input

The input consists of two lines. The first line is X, and the second line is YX and Yonly contain lower-case letters. No strings contain more than 100 letters.

Output

For each test case, output “YES” if you can turn X into Y; otherwise, output “NO”.

Sample Input

abceecba

Sample Output

YES

Problem Source

"6CIT杯"第五届中山大学ICPC新手赛 by 欧阳梓宏

// Problem#: 13290
// Submission#: 3519853
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <stdio.h>
using namespace std;

int t['z' + 1];

int main() {
    
    std::ios::sync_with_stdio(false);
    
    bool isOK = true;
    string s1, s2;
    cin >> s1 >> s2;
    for (int i = 0; i < s1.size(); i++) t[s1[i]]++;
    for (int i = 0; i < s2.size(); i++) t[s2[i]]--;
    for (int i = 'a'; i <= 'z' && isOK; i++) if (t[i]) isOK = false;
    cout << (isOK ? "YES" : "NO") << endl;
    
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值