VRRP原理及双主双备配置实验

VRRP原理及双主双备配置实验

VRRP

通过多台路由设备联合组成一台虚拟路由设备,将虚拟路由设备的ip地址作为用户的默认网关地址实现与外部的通讯。当网关设备发生故障时,VRRP协议能够快速选举新的网关设备承担数据流量,保障网络的可靠通信。VRRP使用ip报文作为传输协议报文,协议号为112,使用固定的组播地址224.0.0.18进行发送,通过协议报文选举出一台路由器作为master,其他设备作为backup,来实现网关备份功能。

VRRP双主双备实验配置及注意要点

一台路由、两台三层交换机与一台二层交换机以及 两个pc机

1、浮动路由
2、vrrp

注意事项
1、浮动路由默认是优先级是60,越小越先,如果是第二条
路由优先级是比默认发的要大,一般配置60以上

2、vrrp:(公有协议)
在多个路由之间运行
可以虚拟出一个或多个网关IP地址(虚拟路由器)
从而实现内网不同网段之间的互通

3、vrrp的工作过程
1.运行vrrp的“多个”路由之间通过vrrp报文的交互,从而选择出
一个最牛的路由器,作为master路由器,以后就用来这个设备来转发数据包
2.master 路由器,仅仅只有一个;其他的路由器称之为backup路由器
3.同时,master 和 backup 路由器,会产生一个虚拟的路由器,也就是一个虚拟IP地址

拓扑图

在这里插入图片描述

配置命令

######LSW3######

#
vlan batch 10 20 100                                             ####划分vlan 10 20 100

#
interface Ethernet0/0/1                                         ####配置g0/0/1为access口 vlan10
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/2                                          ####配置g0/0/1为access口 vlan20
 port link-type access
 port default vlan 20

#
interface GigabitEthernet0/0/1                            ####配置g0/0/1为trunk口 允许vlan10 20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/2                                    ####配置g0/0/2为trunk口 允许vlan10 20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20
######LSW1######
vlan batch 10 20 100                             ####划分vlan 10 20 100

interface Vlanif10
 ip address 192.168.10.10 255.255.255.0                     ####配置IP地址
 vrrp vrid 1 virtual-ip 192.168.10.1                        ####配置虚拟IP地址
 vrrp vrid 1 priority 120                                   ####配置优先级120
 vrrp vrid 1 track interface GigabitEthernet0/0/1   ####配置监听端口,当这个地方down 优先级减10                               vrrp vrid 1 track interface GigabitEthernet0/0/2    ####配置监听端口,当这个地方down 优先级减10
 
#
interface Vlanif20
 ip address 192.168.20.10 255.255.255.0         ####配置IP地址
 vrrp vrid 2 virtual-ip 192.168.20.1            ####配置虚拟IP地址  
 vrrp vrid 2 priority 115                       ####配置优先级115
#
interface Vlanif100
 ip address 11.0.0.2 255.255.255.252            ####配置IP地址
#
interface GigabitEthernet0/0/1                 ####配置g0/0/1为access口 vlan100
 port link-type access
 port default vlan 100

#
interface GigabitEthernet0/0/2                 ####配置g0/0/2为trunk口 允许vlan10 20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20

 #
ip route-static 0.0.0.0 0.0.0.0 11.0.0.1       ####配置默认路由
######LSW2######

#
vlan batch 10 20 100                               ####划分vlan 10 20 100

#
interface Vlanif10                                 
 ip address 192.168.10.20 255.255.255.0            ####配置IP地址
 vrrp vrid 1 virtual-ip 192.168.10.1               ####配置虚拟IP地址
 vrrp vrid 1 priority 115                          ####配置优先级115
#
interface Vlanif20
 ip address 192.168.20.20 255.255.255.0            ####配置IP地址 
 vrrp vrid 2 virtual-ip 192.168.20.1               ####配置虚拟IP地址
 vrrp vrid 2 priority 120                          ####配置优先级120
 vrrp vrid 2 track interface GigabitEthernet0/0/1   ####配置监听端口,当这个地方down 优先级减10
 vrrp vrid 2 track interface GigabitEthernet0/0/2   ####配置监听端口,当这个地方down 优先级减10

#
interface Vlanif100
 ip address 12.0.0.2 255.255.255.252                ####配置IP地址

#
interface GigabitEthernet0/0/1                      ####配置g0/0/1为access口 vlan100
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/2                       ####配置g0/0/2为trunk口 允许vlan10 20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20
#

ip route-static 0.0.0.0 0.0.0.0 12.0.0.1            ####配置默认路由
######R1######

#
interface GigabitEthernet0/0/0                                      ###配置IP地址
 ip address 11.0.0.1 255.255.255.252
#
interface GigabitEthernet0/0/1                                      ###配置IP地址
 ip address 12.0.0.1 255.255.255.252
#

interface LoopBack0                                                 ###配置环回口IP地址
 ip address 1.1.1.1 255.255.255.0
#
ip route-static 192.168.10.0 255.255.255.0 11.0.0.2                 ###配置静态路由
ip route-static 192.168.10.0 255.255.255.0 12.0.0.2 preference 70   ###配置浮动路由
ip route-static 192.168.20.0 255.255.255.0 11.0.0.2 preference 70   ###配置浮动路由
ip route-static 192.168.20.0 255.255.255.0 12.0.0.2                 ###配置静态路由
#

到这里我们实验就做完了现在我们可以抓个包看看。
在这里插入图片描述
从抓包上可以看出在down掉G0/0/1后,端口的优先级别发生了改变由原先的LSW1为主变为了以LSW2为主的数据传输。

展开阅读全文
©️2020 CSDN 皮肤主题: 游动-白 设计师: 上身试试 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值