关于,net Framework各版本兼容性问题

  昨天给同事安装用友的软件,提示要求先安装.net 2.0。本来系统已经安装了.net 4.0,但是还是提示要装.net 2.0。我想请教一下:     

  1. 有些软件要求先安装.NET Framework 2.0、有些软件要求先装.net 3.5,我想问一下,如果我已经安装了高版本的.net,比如.net 4.0,那么是否可以兼容这些需要在旧版.net Framework下运行的应用程序,如果不装低版本的.net,这些应用程序是否能够继续运行在.NET Framework 4上呢?
        (我发现好像不行,那么我可能必须要在自己的系统里安装所有版本的.net Framework,( .Net Framework 2.0, Microsoft .Net Framework 3, Microsoft .Net Framework 3.5 ....,然后要各个版本都要更新一堆补丁.......),这样太麻烦了,占用了不少磁盘空间.)
  2. 各个版本安装有先后顺序要求吗?比如我已经安装了4.0,现在应用软件要求安装2.0,或3.0.或3.5,那么我需要先卸载4.0再按版本顺序逐个安装吗?

Net版本之间是有一定联系的,目前为止微软推出了3个版本的CLR,分别是 1.1, 2.0 , 4.0 并且你要注意的是 .Net 4是基于CLR4的,而.Net 2.0 3.0 3.5都是基于 CLR2.0, 3.0 3.5其实只是在2.0的基础上增加了新的功能,并没有改变CLR。 http://msdn.microsoft.com/zh-cn/library/bb822049.aspx

所以,一旦有程序需要CLR2.0环境,你就需要安装 2.0 3.0 或者 3.5。 建议是安装3.5, 因为这样就已经包含了2.0 3.0 的所有内容;而4.0是需要独立安装的。

CLR2.0 和 CLR4.0安装顺序没有要求,所以你只需要一次性安装一个 .Net 3.5 SP1 和 .Net 4.0 就可以了:


  • 3
    点赞
  • 4
    收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值