UVa 536 Tree Recovery

Tree Recovery
Time Limit: 1000MS Memory Limit: 65536K
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                           D

                                          / \

                                         /   \

                                        B     E

                                       / \     \

                                      /   \     \

                                     A     C     G

                                                /

                                               /

                                              F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).

Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB

题目大意:输入一棵二叉树的先序遍历和中序遍历序列,输出后序遍历序列。

思路: 回顾一下二叉树的三种遍历,我们可以用递归左右子树来解决这道题。当递归的子串长度小于等于3时,为函数递归出口。

这道题可以使用string 的 查找函数find(), 和截取子串函数substr();

关于string 的 find() 函数:
返回类型: size_type,即一个无符号整数。若查找成功,返回第一个字符或子串的位置;若查找失败,返回npos,即-1(打印出来为4294967295)。

函数原型:

size_t find (const string& str, size_t pos = 0) const;

size_t find (const char* s, size_t pos = 0) const;

size_t find (const char* s, size_t pos, size_t n) const;
//前三个函数差不多,不过是第一个的参数是string, 第二三个参数是char*
//第三函数的最后一个参数是指截取 s 的 前 n 个字符。
size_t find (char c, size_t pos = 0) const;
//查找字符c, 若省略第2个参数,则默认从位置0(即第1个字符)起开始查找

关于string 的 substr() 函数:
返回值:
返回一个string, 即截取的子串。
函数原型:

string substr (size_t pos = 0, size_t len = npos) const;
//从pos位置开始,截取长度为len的字符串
//如果只有一个参数,则是复制从位置pos开始一直到字符串结束。
#include<iostream>
#include<string>
using namespace std;
void last(string pre, string in)
{
    char mid = pre[0];
    int m = in.find(mid,0);//获取根节点在中序遍历中的位置
    //递归出口,pre 长度小于等于 3
    if(pre.length() == 3 && m == 1)
    {//如果长度为3,且有左右子树
        cout<<pre[1]<<pre[2]<<mid;
        return ;
    }
    if(pre.length() == 3 && (m == 2 || m == 0))
    {//如果长度为3,但只有左子树或只有右子树
        cout<<pre[2]<<pre[1]<<mid;
        return ;
    }
    if(pre.length() == 1){
        cout<<mid;
        return ;
    }
    if(pre.length() == 2){
        cout<<pre[1]<<mid;
        return ;
    }

    string pl, pr;
    int llen = 0;       
    if(m != 0)
    {//如果有左子树
        string il = in.substr(0,m);
        llen = il.length();
        pl = pre.substr(1,llen);
        last(pl,il);
    }
    if(m != in.length() - 1){//如果有右子树
        string ir = in.substr(m+1);
        int rlen = ir.length();
        pr = pre.substr(1+llen);
        last(pr,ir);
    }
    cout<<mid;
}
int main()
{
    string pre, in;//pre是先序遍历的字符串,in是中序遍历的字符串
    ios::sync_with_stdio(false);
    while(cin>>pre>>in)
    {
        last(pre, in);
        cout<<endl;
    }
    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值