UVa 11292 Dragon of Loowater

11292 - Dragon of Loowater

Time limit: 1.000 seconds
Once upon a time, in the Kingdom of Loowater, a
minor nuisance turned into a major problem.
     The shores of Rellau  Creek in central Loowater
had always been a prime  breeding ground for geese.
Due to the lack of predators,  the geese population 
was out  of control.       
     The people of  Loowater mostly kept clear  of the 
geese.  Occasionally,  a goose would attack one of  the 
pe ople,  and perhaps bite  off a finger or two, but in 
ge neral,  the people tolerated  the geese as a minor 
nui sance.
       One day, a freak mu tation occurred, and one  of the 
geese spawned a  multi-headed fire-breathing  dragon. 
When  the dragon grew up, he threatened to  burn the Kingdom of Loowater to a crisp. Loowater  had a major problem. The king was alarmed, and  called on his knights to slay the dragon and save the  kingdom.
       The knights explained: “To slay the dragon,  we must chop off all its heads. Each knight can chop  off one of the 
dragon's heads. The heads of the dragon  are of different sizes. In order to chop off a head, a  knight must be at least as tall as the diameter of the  head.  The knights’ union demands that for chopping  off a head, a knight must be paid a wage equal to one  gold coin for each centimetre of the knight's height.”
       Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!
Input
The input contains several test cases. The first line of each test case contains two integers between 1 and  20000 inclusive, 
indicating the number n of heads that the dragon has, and the number m of knights in the  kingdom. The next n lines each 
contain an integer, and give the diameters of the dragon’s heads,in  centimetres. The following m lines each contain  an 
integer, and specify the heights of the knights of  Loowater, also in centimetres.
     The last test case is followed by a line containing '0 0'.
Output
For each test case, output a line containing the minimum number of gold coins that the king needs topay to slay the dragon.
 If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’.
Sample Input
2 3
5
4
7
8
4
2 1
5
5
10
0 0
Sample Output
11
Loowater is doomed!
ps:简单题,两个数组排好序,然后选择就可以了。
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
    cin.tie(0);
    ios::sync_with_stdio(false);
    int n, m;
    while(cin>>n>>m)
    {
        if(n == 0 && m == 0)break;
        vector<int> dragon;
        vector<int> warrior;
        int temp;
        for(int i = 0; i < n; i++){
            cin>>temp;
            dragon.push_back(temp);
        }
        for(int i = 0; i < m; i++){
            cin>>temp;
            warrior.push_back(temp);
        }
        if(n > m){
            cout<<"Loowater is doomed!"<<endl;
            continue;
        }
        sort(dragon.begin(), dragon.end());
        sort(warrior.begin(), warrior.end());
        int cnt = 0;
        int cost = 0;
        int index = 0;
        bool flag = 0;
        for(int i = 0; i < n && index < m;)
        {
            if(index < m && dragon[i] <= warrior[index]){
                i++;
                cnt++;
                cost += warrior[index];
                if(cnt == n){
                    flag = 1;
                    break;
                }
            }
            index++;
        }
        if(flag) cout<<cost<<endl;
        else cout<<"Loowater is doomed!"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
08-10
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值