ACM学习感悟——POJ3169(差分约束)

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27. 
这道题的提议就是怎么样合理安排牛,让牛之间的距离最短,将牛的关系可以写成下列公式:d[i+1]-d[i]>=0      d[i]-d[k]>=d1    d[i]-d[k]<=d2
整理可得到  d[i]>=d[k]+d 这种形式,和求最短路的更新形式相同,所以看绿图论算法。
AC代码:
 
//                           //                        //
//  Created by  Team 3 			                       //
//  Copyright (c) 2015年 Team 3. All rights reserved.  //
/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>           
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
#define INF 1<<31
#define cir(i,a,b)  for (int i=a;i<=b;i++)
#define CIR(j,a,b)  for (int j=a;j>=b;j--)
#define CLR(x) memset(x,0,sizeof(x))
typedef long long  ll;
using namespace std;

const int maxn=220010;
long long  pnt[maxn],pre[maxn],head[maxn],w[maxn],cnt;
long long  vis[maxn],d[maxn],counter[maxn];
int N,ML,MD;

void addedge(long long u,long long  v,long long weight)
{
	pnt[cnt]=v;w[cnt]=weight;pre[cnt]=head[u];head[u]=cnt++;
}

long long spfa()
{
	queue<int> q;
	CLR(vis);
	for (long long i=0;i<maxn;i++) d[i]=0x3f3f3f;
	CLR(counter);
	d[1]=0;
	q.push(1);
	vis[1]=1;
	counter[1]++;
	while (!q.empty())
	{
		int x=q.front();
		q.pop();
		vis[x]=0;
		if (counter[x]>N) return -1;                         //出现负圈就说明无法到达终点。
		for (int i=head[x];i!=-1;i=pre[i])
		{
			int v=pnt[i];
			if (d[v]>d[x]+w[i])
			{
				d[v]=d[x]+w[i];
				if (vis[v]==0)
				{
					vis[v]=1;
					counter[v]++;
					q.push(v);
				}
			}
		}
	}
	if (d[N]==0x3f3f3f) return -2;                       
	else return d[N];
}
int main()
{
	while (cin >> N >> ML >> MD)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
//		memset(pre,-1,sizeof(pre));
		for (int i=1;i<=ML;i++)
		{
			long long u,v,dis;
			cin >>u >> v >> dis; 
			addedge(u,v,dis);
		}
		for (int i=1;i<=MD;i++)
		{
			long long u,v,dis;
			cin >> u >> v >> dis;
			addedge(v,u,-dis);                            //这里建图是需要反向建。
		}
//		long long ans=spfa();
		cout << spfa() << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值