动规A - Robberies



Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.        

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
         

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
 

Sample Output

2
4
6  
 
起初,自己是倒推的思路,发现状态不好转移,想了很久之后,用顺推的思路(假设dp[i-1][m]的情况已知且最优) 如下:dp[i][j]表示抢前i家银行,抢到总的钱为j的最大的逃跑几率,有两种决策,一种是 第i家银行不抢 则有dp[i][j]=max(dp[i-1][j],dp[i][j])(为什么要用max函数呢?因为是顺推, 往后增加j之后,可能会发生不可预料的覆盖,用了max 因为未处理的都置为0,可以避免用0覆盖了一些本来不是0的状态)
第二种决策时 第i家银行抢, 同样的 有两种选择:dp[i][j+v[i]]=maxx(dp[i-1][j]*r[i],dp[i-1][j+v[i]]);
v[i]代表第i家银行的钱数,r[i]表示抢第i家银行能逃跑的概率 
这样取最大值,能够保证始终dp[i][j]始终是最大的逃跑几率
然后是AC代码如下:
//
// Create by 神舟 on 2015-02-03
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;
#define CLR(x) memset(x,0,sizeof x)
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=1e2+5;
const int MOD=5e5+5;
double dp[maxn][maxn*100],d,tmp,r[maxn];
int v[maxn],t,m;
double maxx(double a,double b){
    return a>b?a:b;
}
int main()
{
#ifdef LOCAL
 freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
#endif
 ios_base::sync_with_stdio(0);
 scanf("%d",&t);
 while(t--){
        int ans=0;
        CLR(dp);
        scanf("%lf%d",&tmp,&m);
        d=1-tmp;
        for(int i=1;i<=m;i++){
            scanf("%d%lf",v+i,&tmp);
            r[i]=1-tmp;
        }
        for(int i=0;i<=m;i++) dp[i][0]=1;
        for(int i=1;i<=m;i++) for(int j=0;j<maxn*m;j++){
            dp[i][j]=maxx(dp[i-1][j],dp[i][j]);//表示第i个银行不抢
            if(dp[i-1][j]*r[i]>=d){//表示第i个银行抢,能满足逃跑条件,与之前可能已经求出的比较,选择逃跑几率较大的
                dp[i][j+v[i]]=maxx(dp[i-1][j]*r[i],dp[i-1][j+v[i]]);
                //printf("%lf %d %d \n",dp[i][j+v[i]],i,j);
                ans=max(ans,j+v[i]);
            }
        }
        //printf("%lf\n",dp[1][2]);
        printf("%d\n",ans);
 }
 return 0;
}
以上是最开始的,脑壳烧了的时候写的 顺推,写的又渣,又麻烦。下面是逆推之后精简的代码
//
// Create by 神舟 on 2015-02-03
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;
#define CLR(x) memset(x,0,sizeof x)
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=1e2+5;
const int MOD=5e5+5;
double dp[maxn*100],d,tmp,r[maxn];
int v[maxn],t,m;
double maxx(double a,double b){
    return a>b?a:b;
}
int main()
{
#ifdef LOCAL
 freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
#endif
 ios_base::sync_with_stdio(0);
 scanf("%d",&t);
 while(t--){
        int ans=0;
        CLR(dp);
        scanf("%lf%d",&tmp,&m);
        d=1-tmp;
        for(int i=1;i<=m;i++){
            scanf("%d%lf",v+i,&tmp);
            r[i]=1-tmp;
        }
        dp[0]=1;
        for(int i=1;i<=m;i++) for(int j=maxn*m;j>=v[i];j--){
            if(dp[j]>=d||dp[j-v[i]]*r[i]>=d){
                dp[j]=maxx(dp[j],dp[j-v[i]]*r[i]);
                ans=max(ans,j);
                //printf("%d %lf %d\n",i,dp[j],j);
            }
        }
        printf("%d\n",ans);
 }
 return 0;
}
想出来的逆推思路,压缩成一维的AC代码,看着简洁了好多,看来我需要更深刻的去理解
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值