平衡状态数量+01背包



Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input
2 4
-2 3
3 4 5 8

Sample Output

2
这道题,最开始,想的用暴力dfs来写,看了下复杂度简直不可能,最后苦思冥想 想不出状态,然后题解 发现是新东西,因此写下这篇题解
题目大意是有一个天平,上面-15~15位置(负数表示天平左边) 有或者无勾,有勾的可以挂砝码  每个砝码1-25的重量,然后输入  勾的数量 玛法数量,勾的位置,砝码重量
要求是用完所有砝码,然后找出,能使得天平平衡的挂法的种类数
然后引入一个平衡度的概念,平衡度表示为挂完砝码后,左边的玛法*力臂的总重量 减去右边砝码*力臂的总重量 范围是 20*15*25=7500 也就是从-7500到7500
然后记录达到这个平衡度的挂法数
因为坐标无负 那么就映射0~15000 -> -7500~7500
dp[i][j]表示 用前i个砝码,达到j的平衡度,的挂法数
那么这么转移dp[i][j+c[k]*w[i]]+=dp[i-1][j]        c[k]表示挂在c[k]位置,也就是力臂 w[i]表示第i个砝码的重量
初始化 dp[0][7500]=1表示不挂的时候 天平平衡,只有一种挂法(那就是不挂)
代码如下:
 //
// Create by 神舟 on 2015-02-14
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;

#define CLR(x) memset(x,0,sizeof x)
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=15500;
const int MOD=5e5+5;
int dp[25][maxn];
int c[25],w[25];
int main()
{
#ifdef LOCAL
 freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
#endif
 ios_base::sync_with_stdio(0);

 int n,m;
 while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=1;i<=n;scanf("%d",&c[i++]));
        for(int i=1;i<=m;scanf("%d",&w[i++]));
        CLR(dp);
        dp[0][7500]=1;
        for(int i=1;i<=m;i++) for(int j=0;j<=15000;j++) if(dp[i-1][j]){//如果前一种j的平衡度挂法为0,那么没必要再挂了 ,可以优化
            for(int k=1;k<=n;k++) dp[i][j+c[k]*w[i]]+=dp[i-1][j];
        }
        printf("%d\n",dp[m][7500]);
 }

 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值