1113: [Poi2008]海报PLA

1113: [Poi2008]海报PLA

Time Limit: 10 Sec   Memory Limit: 162 MB
Submit: 986   Solved: 648
[ Submit][ Status][ Discuss]

Description

N个矩形,排成一排. 现在希望用尽量少的矩形海报Cover住它们.

Input

第一行给出数字N,代表有N个矩形.N在[1,250000] 下面N行,每行给出矩形的长与宽.其值在[1,1000000000]2 1/2 Postering

Output

最少数量的海报数.

Sample Input

5
1 2
1 3
2 2
2 5
1 4

Sample Output

4

HINT

Source

[ Submit][ Status][ Discuss]

维护一个单调栈
#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<bitset>
#include<algorithm>
#include<cstring>
#include<map>
#include<stack>
#include<set>
#include<cmath>
#include<ext/pb_ds/priority_queue.hpp>
using namespace std;

const int maxn = 3E5;

int n,Ans,h[maxn];

stack <int> s;

int main()
{
	#ifdef DMC
		freopen("DMC.txt","r",stdin);
	#endif
	
	cin >> n;
	for (int i = 1; i <= n; i++) {
		int x,y; scanf("%d%d",&x,&y);
		h[i] = y;
	}
	++n;
	for (int i = 1; i <= n; i++) {
		while (!s.empty()) {
			int now = s.top(); 
			if (now <= h[i]) break;
			s.pop(); ++Ans;
		}
		if (s.empty()) s.push(h[i]);
		else {
			int now = s.top();
			if (now == h[i]) continue;
			s.push(h[i]);
		}
	}
	cout << Ans;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值