2561: 最小生成树
Time Limit: 10 Sec Memory Limit: 128 MBSubmit: 1724 Solved: 829
[ Submit][ Status][ Discuss]
Description
给定一个边带正权的连通无向图G=(V,E),其中N=|V|,M=|E|,N个点从1到N依次编号,给定三个正整数u,v,和L (u≠v),假设现在加入一条边权为L的边(u,v),那么需要删掉最少多少条边,才能够使得这条边既可能出现在最小生成树上,也可能出现在最大生成树上?
Input
第一行包含用空格隔开的两个整数,分别为N和M;
接下来M行,每行包含三个正整数u,v和w表示图G存在一条边权为w的边(u,v)。
最后一行包含用空格隔开的三个整数,分别为u,v,和 L;
数据保证图中没有自环。
接下来M行,每行包含三个正整数u,v和w表示图G存在一条边权为w的边(u,v)。
最后一行包含用空格隔开的三个整数,分别为u,v,和 L;
数据保证图中没有自环。
Output
输出一行一个整数表示最少需要删掉的边的数量。
Sample Input
3 2
3 2 1
1 2 3
1 2 2
3 2 1
1 2 3
1 2 2
Sample Output
1
HINT
对于20%的数据满足N ≤ 10,M ≤ 20,L ≤ 20;
对于50%的数据满足N ≤ 300,M ≤ 3000,L ≤ 200;
对于100%的数据满足N ≤ 20000,M ≤ 200000,L ≤ 20000。
Source
参考bzoj2521的建图。。。bzoj2521
边集要开四倍。。。。一开始只开了两倍。。。结果WA不止。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 2E4 + 20;
const int maxm = 8E5 + 80;
const int INF = 1E9 + 233;
struct E{
int to,cap,flow; E(){}
E(int to,int cap,int flow): to(to),cap(cap),flow(flow){}
}edgs[maxm];
int n,m,cnt,s,t,A[maxm],B[maxm],w[maxm],cur[maxn],L[maxn];
vector <int> v[maxn];
queue <int> Q;
void Add(int x,int y,int cap)
{
v[x].push_back(cnt); edgs[cnt++] = E(y,cap,0);
v[y].push_back(cnt); edgs[cnt++] = E(x,0,0);
}
bool BFS()
{
for (int i = 1; i <= n; i++) L[i] = 0;
L[s] = 1; Q.push(s);
while (!Q.empty())
{
int k = Q.front(); Q.pop();
for (int i = 0; i < v[k].size(); i++)
{
E e = edgs[v[k][i]];
if (e.cap == e.flow || L[e.to]) continue;
L[e.to] = L[k] + 1; Q.push(e.to);
}
}
return L[t];
}
int Dinic(int x,int a)
{
if (x == t) return a; int flow = 0;
for (int &i = cur[x]; i < v[x].size(); i++)
{
E &e = edgs[v[x][i]];
if (e.cap == e.flow || L[e.to] != L[x] + 1) continue;
int f = Dinic(e.to,min(a,e.cap - e.flow));
if (!f) continue; e.flow += f; flow += f;
a -= f; edgs[v[x][i]^1].flow -= f; if (!a) return flow;
}
if (!flow) L[x] = -1; return flow;
}
int MaxFlow()
{
int ret = 0;
while (BFS())
{
for (int i = 1; i <= n; i++) cur[i] = 0;
ret += Dinic(s,INF);
}
return ret;
}
int getint()
{
char ch = getchar(); int ret = 0;
while (ch < '0' || '9' < ch) ch = getchar();
while ('0' <= ch && ch <= '9')
ret = ret * 10 + ch - '0',ch = getchar();
return ret;
}
int main()
{
#ifdef DMC
freopen("DMC.txt","r",stdin);
#endif
cin >> n >> m;
for (int i = 1; i <= m; i++)
A[i] = getint(),B[i] = getint(),w[i] = getint();
++m; A[m] = getint(); B[m] = getint(); w[m] = getint();
for (int i = 1; i < m; i++)
if (w[i] < w[m]) Add(A[i],B[i],1),Add(B[i],A[i],1);
s = A[m]; t = B[m]; int Ans = MaxFlow();
cnt = 0; for (int i = 1; i <= n; i++) v[i].clear();
for (int i = 1; i < m; i++)
if (w[i] > w[m]) Add(A[i],B[i],1),Add(B[i],A[i],1);
cout << Ans + MaxFlow() << endl;
return 0;
}