POJ 3984 迷宫问题

定义一个二维数组:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

直接递归打印就行了

#include <stdio.h>
#include <string.h>
#include <queue>
#include <string>
#include <iostream>
using namespace std;
int t;
int v[6][6];
int Map[6][6];
struct Step{
	int x,y;
}p[6][6],step[40];
int d[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
struct node{
	int x, y;
}pre,nex;
void print(int x,int y) {
	step[t].x = x;
	step[t].y = y;
	t++;
	if(x == 0 && y == 0) return ;
	int dx = p[x][y].x;
	int dy = p[x][y].y;
	print(dx,dy);
}
void bfs() {
	queue<node> q;
	pre.x = 0;
	pre.y = 0;
	v[0][0] = 1;
	q.push(pre);
	while(!q.empty()) {
		nex = q.front();
		q.pop();
		if(nex.x == 4 && nex.y == 4) {
			print(4,4);
			return ;
		}
		for(int i = 0; i < 4; i++) {
			int dx = d[i][0] + nex.x;
			int dy = d[i][1] + nex.y;
			if(dx>=0&&dy>=0&&dx<5&&dy<5) {
				if(Map[dx][dy] == 0 && v[dx][dy] == 0) {
					pre.x = dx;
					pre.y = dy;
					v[dx][dy] = 1;
					p[dx][dy].x = nex.x;
					p[dx][dy].y = nex.y;
					q.push(pre);
				}
			}
		}
	}
	return ;
}
int main() {
	t = 0;
	memset(v, 0 , sizeof(v));
	for(int i = 0; i < 5; i++) {
		for(int j = 0; j < 5; j++) {
			scanf("%d",&Map[i][j]);
		}
	}
	bfs();
	for(int i = t-1; i >= 0; i--)
	printf("(%d, %d)\n",step[i].x,step[i].y);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值