POJ 2492 A Bug's Life

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.

参考了大神们的代码,我们可以将a的异性设为a+n,如果a和b是异性,所以a+n和b+n是异性,那么a和b+n是同性,b和a+n为同性,我们可以将他们列在一个集合里,这样就转化为裸地并查集了。
具体代码如下:
#include <stdio.h>
#include <string.h>
using namespace std;
struct node{
	int x, y;
}s[1000055];
int f[4050];
void init(int n) {
	for(int i = 0; i <= 2*n; i++){
		f[i] = i;
	}
}
int getf(int v) {
	if(v != f[v]) {
		f[v] = getf(f[v]);
	}
	return f[v];
}
void merge(int v, int u) {
	int t1 = getf(v);
	int t2 = getf(u);
	if(t1 != t2) {
		f[t1] = t2;
	}
}
int judge(int v, int u) {//判断是否为同性 
	int t1 = getf(v);
	int t2 = getf(u);
	if(t1 != t2) return 1;
	else return 0;
}
int main() {
	int N, M;
	int n, m;
	int a, b;
	scanf("%d",&N);
	for(M = 1; M <= N; M++) {
		scanf("%d%d",&n, &m);
		init(n);
		for(int i = 0; i < m; i++) {
			scanf("%d%d",&s[i].x, &s[i].y);	
		}
		bool flag = false;
		for(int i = 0; i < m; i++) {
			a = s[i].x;
			b = s[i].y;
			if(judge(a, b) || judge(a+n, b+n)) {//判断,如果两者都是同性,就break 
				merge(a, b+n);
				merge(b, a+n);
			}
			else {
				flag = true;
				break;
			}
		}
		if(M != 1) printf("\n");//POJ的输出很气人,无聊的PE有何意义 
		printf("Scenario #%d:\n",M);
		if(flag) printf("Suspicious bugs found!\n");
		else printf("No suspicious bugs found!\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值