POJ 2431 Expedition

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 
Input
* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2
Hint
INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题意:第一行一个数字N:代表接下来有N个加油站的输入。

   每个加油站输入Ai,Bi,分表表示距离终点的距离;加油的量

   最后一行输入两个数字:L,P:分别代表总路程;初始的油量。

问汽车从起点开往终点,最少进行几次加油,可以到达终点,每单位的汽油能行驶单位的路程。

题解:我们可以假设到达某一加油站后不直接加油,而是在汽车到达某一点后没油的情况下进行加油(不会影响结果)。因为希望到达终点时加油次数尽可能少,所以此时应该是经过的所有加油站中可以加的油量最大的那个加油站。我们用优先队列把经过的加油站压入队列,然后当汽车没油的时候,我们再把加油量最多的那个弹出就行了。具体代码如下:

#include <queue>
#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
struct node{
	int A,B;
}s[10005];
bool cmp(node x, node y) {
	return x.A<y.A;
}
int main() {
	int N;
	int sum = 0;
	int L, P;
	scanf("%d",&N);
	for(int i = 0; i < N; i++) {
		scanf("%d%d",&s[i].A,&s[i].B);
	}
	scanf("%d%d",&L,&P);
	for(int i = 0; i < N; i++) {
		s[i].A = L - s[i].A;
	}
	sort(s, s+N, cmp);
	s[N].A = L, s[N].B = 0;
	priority_queue<int> q;
	for(int i = 0; i <= N; i++) {
		while(P < s[i].A) {
			if(q.empty()) {
				puts("-1");
				return 0;
			}
			P += q.top();
			q.pop();
			sum++;
		}
		q.push(s[i].B);
	}
	printf("%d\n",sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值