Hdoj 1159.Common Subsequence 题解

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003


思路

  • \(X=(x_1,x_2,x_3,..)\)\(Y = (y_1,y_2,y_3,...)\)的最长公共子序列\(LCS(X,Y)\)
  • 最优子结构证明
    • 如果\(x_n==y_n\)那么\(LCS(X_{n-1},Y_{n-1})\)就是一个子问题
    • 否则就是$,,LCS = max(LCS(X_{n-1},Y_m),LCS(X_n,Y_{m-1})) $

证明完成之后,显然可以容易得到状态转移式,用\(f[i][j]\)表示长度为i的s1和长度为j的s2的最长公共子序列的长度,详见注释:

#include<bits/stdc++.h>
using namespace std;
int f[1001][1001];
int main()
{
    string s1;
    string s2;
    while(cin>>s1>>s2)
    {
        int len1 = s1.size();
        int len2 = s2.size();
        memset(f,0,sizeof(f));//初始归0
        for(int i=1;i<=len1;i++)
            for(int j=1;j<=len2;j++) 
                if(s1[i-1] == s2[j-1])
                    f[i][j] = max(f[i][j],f[i-1][j-1] + 1);//如果末尾相等,就是比较前n-1长度的LCS+1和自己的
                else
                    f[i][j] = max(f[i][j-1], f[i-1][j]);//如果末尾元素不相等就划分到子问题里
        cout << f[len1][len2] << endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/MartinLwx/p/9822825.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值