zoj_2966 Build TheElectric System

B - Build TheElectric System

Crawling in process...Crawlingfailed Time Limit:2000MS     Memory Limit:65536KB    64bit IO Format:%lld & %llu

Submit Status

题目连接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2966

Description

In last winter, therewas a big snow storm in South China. Theelectric system was damaged seriously. Lots of power lines were broken and lotsof villages lost contact with the main power grid. The government wants toreconstruct the electric system as soon as possible. So, as a professionalprogrammer, you are asked to write a program to calculate the minimum cost toreconstruct the power lines to make sure there's at least one way between everytwo villages.

Input

Standard input willcontain multiple test cases. The first line of the input is a single integerT(1 <= T <= 50) which is the number of test cases. And it will befollowed byT consecutive test cases.

In each test case, thefirst line contains two positive integersN and E (2 <= N<= 500, N <= E <= N * (N - 1) / 2),representing the number of the villages and the number of the original powerlines between villages. There followE lines, and each of them contains threeintegers, A, B,K (0 <= A, B < N,0 <= K < 1000). A and B respectively means the indexof the starting village and ending village of the power line. IfK is 0,it means this line still works fine after the snow storm. If K is apositive integer, it means this line will cost K to reconstruct. Therewill be at most one line between any two villages, and there will not be anyline from one village to itself.

Output

For each test case inthe input, there's only one line that contains the minimum cost to recover theelectric system to make sure that there's at least one way between every twovillages.

Sample Input

1

3 3

0 1 5

0 2 0

1 2 9

Sample Output

5

 

解题思路:这个题目是一个比较典型的并查集,我用一个结构体来保存输入村庄的起点和终点和全职,需要注意的是数组空间的大小,对结构体数组进行从小到大排序,然后依次取出节点进行合并查找,记录集合中节点的数量是否等于村庄的数量,如果等于,直接输出总和

      

 

代码:

 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#define MAX 502
using namespace std;
struct edge
{
	int start;
	int end;
	int weight;
};
edge e[MAX*MAX/2];

int point[MAX];
int number=1;//记录合并的点数
int sum=0;//记录总长度
int T,N,E;//测试用例,点数,边数

int findSet(int t)
{
	if(t==point[t])
		return point[t];
	//number++;
	return point[t]=findSet(point[t]);
}

void unionSet(edge temp)
{
	int a=findSet(temp.start);
	int b=findSet(temp.end);
	if(a==b)//x,y具有相同的祖先
		return ;
	point[a]=b;//合并——b的父亲变为a
	number++;
	sum+=temp.weight;
}

int main()
{
	scanf("%d",&T);
	int a,b,k;
	int i,j;
	while(T--)
	{
		number=1;
		sum=0;
		scanf("%d%d",&N,&E);
		for(i=0;i<N;i++)
		{
			point[i]=i;
		}
		//E条边
		
		for(i=0;i<E;i++)
		{
			scanf("%d%d%d",&e[i].start,&e[i].end,&e[i].weight);
		}
		for(i=0;i<E;i++)
		{
			for(j=i;j<E;j++)
			{
				if(e[i].weight>e[j].weight)
				{
					edge temp;
					temp=e[i];
					e[i]=e[j];
					e[j]=temp; 
				}	
			}
		}
		for(i=0;i<E;i++)
		{
			if(number==N)
			{
				printf("%d\n",sum);
				break;
			}
			unionSet(e[i]);
		}
		
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
使用 JavaScript 编写的记忆游戏(附源代码)   项目:JavaScript 记忆游戏(附源代码) 记忆检查游戏是一个使用 HTML5、CSS 和 JavaScript 开发的简单项目。这个游戏是关于测试你的短期 记忆技能。玩这个游戏 时,一系列图像会出现在一个盒子形状的区域中 。玩家必须找到两个相同的图像并单击它们以使它们消失。 如何运行游戏? 记忆游戏项目仅包含 HTML、CSS 和 JavaScript。谈到此游戏的功能,用户必须单击两个相同的图像才能使它们消失。 点击卡片或按下键盘键,通过 2 乘 2 旋转来重建鸟儿对,并发现隐藏在下面的图像! 如果翻开的牌面相同(一对),您就赢了,并且该对牌将从游戏中消失! 否则,卡片会自动翻面朝下,您需要重新尝试! 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox, 以获得更好、更优化的游戏体验。要玩游戏,首先,通过单击 memorygame-index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

疯的世界

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值