B - Agri-Net解题报告(吴忠健)

B - Agri-Net
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题目大意:给出n个村庄之间的距离,要求把每个村庄都用网线联通,求连通后的网线的最小长度。

思路:最小生成树


解题代码:

#include<stdio.h>
const int Max=1000005;
int map[100][100];
int low[100];
int main()
{
int i,j,k,n,min;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
 scanf("%d",&map[i][j]);//输入距离
 }
for(i=0;i<n;i++)
low[i]=map[0][i];//先存第一行的距离,即此时的做短距离
k=n-1;//连通后的k条路
int ans=0;
while(k--)
{
 
   int max=Max+1;
for(j=0;j<n;j++)
{
if(low[j]&&max>low[j])//判断每行中的非零且最小值
{
max=low[j];
min=j;
}
}
ans+=low[min];//最小权值相加
low[min]=0;将取过的点置零
for(j=0;j<n;j++)
{
if(low[j]>map[min][j])//min指明行数的改变,更改low的值
low[j]=map[min][j];
}
}
printf("%d\n",ans);
}
return 0;
}
 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值