ZOJ 1914 Arctic Network(解题报告)

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

 Input

 The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

 Output

 For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1

2 4

0 100
0 300
0 600
150 750  Sample Output

212.13
 这个题目是考察最小生成树,咱们用并查集来解决这类问题。首先将所有点的连线的长度保存下来,从大到小的排序,然后从小的开始把他们并到不同的集合中去在同一个集合中的肯定是能互相通信的,具体见代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct edge 
{
	int from;
	int to;
	int dis;
};
 
int coor[501][2];
edge dist[500*500];
int f[500+10];
int ans[500+10];
 
int find(int x)
{
	if(f[x]==x)
	{
		return x;
	}
	else return find(f[x]);
}
 
int distances(int i,int j)
{
	return (coor[i][0]-coor[j][0])*(coor[i][0]-coor[j][0])+(coor[i][1]-coor[j][1])*(coor[i][1]-coor[j][1]);
}
 
int cmp(edge a,edge b)
{
	return a.dis<b.dis;
}
 
int main()
{
	int i,j,t,s,p;
	int n=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&s,&p);
		for(i=0;i<p;i++)
		{
			scanf("%d%d",&coor[i][0],&coor[i][1]);
		}
		n=0;
		for(i=0;i<p-1;i++)
		{
			for(j=i+1;j<p;j++)
			{
				dist[n].from=i;//保存线段的开始点 
				dist[n].to=j;//保存线段的终点 
				dist[n].dis=distances(i,j);//求各个连线的长度 
				n++;
			}
		}
		sort(dist,dist+n,cmp);//从大到小排序 
		for(i=0;i<p;i++)
		{
			f[i]=i;
		}
		int total = 0;
		double temp;
		for(i=0;i<n;i++)//并查集开始 
		{
			if(find(dist[i].from)!=find(dist[i].to))//他们不在同一个集合的时候,将他们的代表元合并,两个集合就合并在一起啦,神奇吧 
			{
				f[find(dist[i].from)]=find(dist[i].to);
				total++;//这个记录的是radio的个数 
				temp=dist[i].dis;
				if(total==p-s)//用这么多radio够了,结束 
				{
					break;
				}
			}
		}
		printf("%.2lf\n",sqrt(temp));//为什么要开根号呢,前面没开啊 哈哈。 
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值