POJ-2349题解

POJ-2349

题目描述

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2
3
4
5
6
1
2 4
0 100
0 300
0 600
150 750

Sample Output

1
212.13

看不懂题目的话就翻译

解题思路

使用prim构造最小生成树
prim是什么 具体请google或者百度搜一搜 但是经历了模拟考用prim构建最小生成树的悲惨过程
建议去还是学一下Kruskal算法

推荐博客地址这篇文章

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>

#include <algorithm>

using namespace std;

#define MAXINT 0x3f3f3f3f

struct Node
{
int x,y;
}l[600];

int m,n;
double dis[600],d[605][605];
bool book[600];

void print()
{
for (int i=1;i<=n;i++)
dis[i]=d[1][i];
book[1]=1;
for (int i=1;i<=n-1;i++)
{
int k=0,mm=MAXINT;
for (int j=1;j<=n;j++)
if (dis[j]<mm && book[j]==0)
{
mm=dis[j];
k=j;
}
book[k]=1;
for (int j=1;j<=n;j++)
if (dis[j]>d[j][k] && book[j]==0)
dis[j]=d[j][k];
}
sort(dis+1,dis+n+1);



//for (int i=1;i<=n;i++)
// cout<<dis[i]<<" ";
printf("%.2f\n",dis[n-m+1]);
}

int main()
{
int x;
cin>>x;
while (x>0)
{
memset(book,0,sizeof(book));
cin>>m>>n;
for (int i=1;i<=n;i++)
{
cin>>l[i].x>>l[i].y;
}
for (int i=1;i<=n;i++)
for (int j=1;j<=n;j++)
{
if (i==j)
d[i][j]=0;
else
d[i][j]=sqrt((l[i].x-l[j].x)*(l[i].x-l[j].x)+(l[i].y-l[j].y)*(l[i].y-l[j].y));
}
/*
for (int i=1;i<=n;i++)
{
for (int j=1;j<=n;j++)
cout<<d[i][j]<<" ";
cout<<endl;
}
*/

print();
x--;
}
return 0;
}

这个用的还是prim 因为打起来跟djikstra很像 而去对于这题比较方便

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

cpongo11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值