题目链接: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2965
原题链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2965
2012年9月15日组队赛
In a party held by CocaCola company, several students stand in a circle and play a game.
One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.
For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.
During a game, you may hear a consecutive ofp "CocaCola"s. So what is the minimum number that can make this situation happen?
For examplep = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.
Input
Standard input will contain multiple test cases. The first line of the input is a single integerT (1 <= T <= 100) which is the number of test cases. And it will be followed byT consecutive test cases.
There is only one line for each case. The line contains only one integerp (1 <= p <= 99).
Output
Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of thep "CocaCola"s stands for.
Sample Input
2 2 3
Sample Output
27 70
Author: HANG, Hang
Source: The 5th Zhejiang Provincial Collegiate Programming Contest
题目大意:
寻找满足一下条件之一的数字:
1能够被7整除。
2某一位数是7。
测试数据:
第一行:测试样例的数目N。
剩下N行:每行输入一个数字P,求有P个连续的这样的数字的,最小的 起始满足条件的数字。
思路:打表即可。
因为p较小,最大才99,又从700-799就可以满足全部条件。可以打表出来,找出每个连续的一段满足要求的数,保存起来即可,由题目知道
p=1,ans=7;
p=2,ans=27;
p=3、4、5...10,ans=70;
p=11,ans=270;
p=12...99,ans=700;
所以直接保存在数组中,最后输出结果就O了。
//Accepted 160 KB 0 ms C (gcc 4.4.5) 300 B 2012-09-15
#include<stdio.h>
int ans[100]={0,7,27,70,70,70,70,70,70,70,70,
270};
int main()
{
int test;
int p;
scanf("%d",&test);
int i;
for(i=12;i<=100;i++)
ans[i]=700;
while(test--)
{
scanf("%d",&p);
printf("%d\n",ans[p]);
}
return 0;
}