HDU 1030 纯数学 找规律

题目如下:大意是求两个三角形之间要通过多少条边

Delta-wave

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4938    Accepted Submission(s): 1875


Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below. 



The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route. 

Write the program to determine the length of the shortest route connecting cells with numbers N and M. 
 

Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
 

Output
Output should contain the length of the shortest route.
 

Sample Input
  
  
6 12
 

Sample Output
  
  
3
 
#include<stdio.h>
#include<math.h>
void main()
{
	int m,n,h1,h2,x,y,temp,num,p1,p2;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		h1=sqrt((float)m);
		if(h1!=sqrt((float)m))
			h1++;
		h2=sqrt((float)n);
		if(h2!=sqrt((float)n))
			h2++;
		x=m-(h1-1)*(h1-1);
		y=n-(h2-1)*(h2-1);
		p1=(h1*h1-m)/2+1;
		p2=(h2*h2-n)/2+1;
		if(h1>h2)
		{
			temp=h2;
			h2=h1;
			h1=temp;
			temp=x;
			x=y;
			y=temp;
			temp=p1;
			p1=p2;
			p2=temp;
		}
		num=(h2-h1-1)*2;
		if(x%2==0)
			num++;
		if(y%2==0&&x<=y&&p1<=p2)
			num++;
		else
			num+=2;
		if(x>y)
			num+=x-y;
		if(p1>p2)
			num+=y-2*(h2-p1)-1;
		printf("%d\n",num);
	}
}


主要是分两个方向划分到同一个正三角形里面,然后中间的行数*2+头尾吧,头尾三角形分为正反两种,分情况讨论,也不怎么能说清楚啊。。。

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值