坑爹水题——Uva10036

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=&problem=976&mosmsg=Submission+received+with+ID+11932248

Problem B: Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left onedigit at a time. Many find the "carry" operation - in which a 1 iscarried from one digit position to be added to the next - to bea significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so thateducators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations thatwould result from adding the two numbers, in the formatshown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.



当答案为1 和大于1时,输出时不同的。。。。




#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    unsigned int  a,b,c,ans;
    while(cin>>a>>b){
        if(a==0&&b==0)
            break;

        c=ans=0;
        while(a!=0 || b!=0 ){
            c+=a%10 + b%10;
            a/=10;
            b/=10;
            if(c>9){
               ans++;
            }
            c/=10;
        }
        if(ans==0)
            cout<<"No carry operation."<<endl;
        else if(ans==1)
            cout<<"1 carry operation.\n";
        else
            printf("%d carry operations.\n",ans);

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值