简单题 —— Crossing Rivers —— 2009 Asia Wuhan Regional Contest Hosted by Wuhan University

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3232

Crossing Rivers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 429    Accepted Submission(s): 225


Problem Description
You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

Fortunately, there is one "automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.

Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the  expected time to reach B from A? Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is  uniformly chosenfrom interval [0,  L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.
 

Input
There will be at most 10 test cases. Each case begins with two integers  n and  D, where  n (0 <=  n <= 10) is the number of rivers between A and B,  D (1 <=  D <= 1000) is the distance from A to B. Each of the following  n lines describes a river with 3 integers:  p, L and  v (0 <=  p <  D, 0 <  L <=  D, 1 <=  v <= 100).  p is the distance from A to the left bank of this river,  L is the length of this river,  v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by  n=D=0, which should not be processed.
 

Output
For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.
 

Sample Input
  
  
1 1 0 1 2 0 1 0 0
 

Sample Output
  
  
Case 1: 1.000 Case 2: 1.000
 

Source
 

Recommend
chenrui

 ————————————————————————————————————————————————————————————————


          题目大意:说从A(左边)到B(右边),之间有些河流,每条河流有一条船。告诉你A、B之间的距离,河流的数量,河流距离A的距离,河流的宽度,船在这条河中的速度。然后是每条河中的船不一定在初始状态时就在河边,而是随机的在河中央,或在河的对面。但这都不影响。因为第一个样例等于已经告诉你概率的计算公式了。


       做这题的唯一不明白的地方,为什么ans(即输出的总时间)用float会wrong,而用double才AC,可能和精度有关吧,但只要求小数点后3位啊。不懂。


#include <algorithm>
#include <iostream>
#include <iomanip>
#include <string>
#include <bitset>

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>

#include <map>
#include <stack>
#include <queue>
#include <set>
#include <list>

#include <utility>

using namespace std;


struct boat
{
    int p, l, v;
    bool operator < (const struct boat bb)const
    {
        return this -> p - bb.p;
    }
  //  bool operator > (const struct boat bb)const
  //  {
 //       return this -> p - bb.p;
 //   }
};

struct boat b[500];


int cmp(const void *x, const void *y)
{
    return ((struct boat*)x) -> p - ((struct boat*)y) -> p;
}

int main()
{
//	srand(time(NULL));
    int n, d, lct,ca;
    double ans;
    ca = 1;
    scanf("%d %d", &n ,&d);
    while (  n != 0 || d != 0)
    {
        ans = 0.000000;
        for (int j = 0; j < n; j++)
        {
            cin >> b[j].p >> b[j].l >> b[j].v;
        }
        qsort(b, n, sizeof (struct boat), cmp);
       // sort(b, b + n);
        lct = 0;
        for (int j= 0; j < n; j++)
        {
            ans = ans + (b[j].p - lct);
            lct = b[j].p + b[j].l;
            ans += (float)(b[j].l * 2 + 0.0000) /(float)(0.0000+  b[j].v);

        }
        ans = ans + d - lct;
        printf("Case %d: %.3f\n\n",ca++, ans);
        scanf("%d %d", &n ,&d);
    }

	return 0;
}
















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值