HDU 2612 Find a way (双bfs)

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
 

Sample Output
66
88
66

双bfs全都跑一遍,然后再遍历求最小步数合,但是这里有个坑,参考了别人题解后才发现。

#include <iostream>
#include <queue>
#include <string.h>
#include <cstdio>
#define MINX 1e8
using namespace std;

typedef struct
{
    int x;
    int y;
    int step;
} node;

char map[205][205];
int sum[2][205][205];
int vis[205][205];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int x[2],y[2];
int n,m;

void bfs(int t, int x, int y)
{
     queue <node> q;
     node temp,now;
     vis[x][y] = 1;
     now.x = x;
     now.y = y;
     now.step = 0;
     q.push(now);
     while(!q.empty())
     {
         now = q.front();
         q.pop();
         if(map[now.x][now.y] == '@')
            sum[t][now.x][now.y] = now.step;
         for(int i= 0; i < 4; i++)
         {
             temp.x = now.x + dir[i][0];
             temp.y = now.y + dir[i][1];
             if(temp.x >= 0&&temp.x < n&&temp.y >= 0&&temp.y < m&&map[temp.x][temp.y] != '#'&&!vis[temp.x][temp.y])
             {
                 temp.step = now.step + 1;
                 vis[temp.x][temp.y] = 1;
                 q.push(temp);
             }
         }
     }

}
int main()
{
    while(cin>>n>>m)
    {
        for(int i = 0; i < n; i++)
        {
            cin>>map[i];
            for(int j = 0; j < m; j++)
            {
                if(map[i][j] == 'Y')
                {
                    x[0] = i;
                    y[0] = j;
                }
                if(map[i][j] == 'M')
                {
                    x[1] = i;
                    y[1] = j;
                }
            }
        }
        memset(sum, 0, sizeof(sum));
        for(int i = 0; i < 2; i++)
        {
            memset(vis, 0, sizeof(vis));
            bfs(i, x[i], y[i]);
        }
        int minx = MINX;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                if(sum[0][i][j])//这里不能用map[i][j] == '@'进行判断,因为可能会有某些kfc无法通过,这样就会导致该点值为0,从而改变结果
                {
                    if(minx > sum[0][i][j] + sum[1][i][j])
                        minx = sum[0][i][j] + sum[1][i][j];
                }
            }
        }
        cout<<minx * 11<<endl;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值