HDU 2162 Find a way(双BFS+最短路)

153 篇文章 0 订阅
29 篇文章 0 订阅

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9772    Accepted Submission(s): 3187


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 

Author
yifenfei
 

Source

   

题意:

‘Y’和‘M’分别表示两个人所在位置,‘@’表示KFC的位置,‘#’代表障碍物,‘ . ’代表路,两人约在同一个KFC见面,问两人所走的路径之和的最小值。

思路:

一开始从每个KFC开始,分别求出到两人的路径之和,再找到最小的,但是TLE了。原因是多次遍历图,遍历的次数为KFC数量的两倍!!后来找到解决方法:依旧从两个人出发,求出到每个KFC的最短路径,最后再遍历图,如果是KFC,则算出两人到此KFC的路径之和,便可得到最短路径。

AC代码:

#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>
char a[220][220];
bool vis[220][220];
int dis[2][220][220];
using namespace std;
int n,m;
int dir[4][2]= {0,1,1,0,0,-1,-1,0};
struct node
{
    int x,y,step;
};
bool OK(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    return true;
}
void BFS(int idx,int x,int y)//
{
    memset(vis,false,sizeof(vis));
    vis[x][y]=true;
    queue<node>q;
    node cur,next;
    cur.x=x;
    cur.y=y;
    cur.step=0;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        //cout<<"x="<<cur.x<<",y="<<cur.y<<",t="<<cur.step<<endl;
        if(a[cur.x][cur.y]=='@')
        {
            dis[idx][cur.x][cur.y]=cur.step;
        }
        for(int i=0; i<4; i++)
        {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            if(OK(next.x,next.y)&&!vis[next.x][next.y]&&a[next.x][next.y]!='#')
            {
                vis[next.x][next.y]=true;
                next.step=cur.step+1;
                q.push(next);
            }
        }
    }


}
int main()
{
    while(cin>>n>>m)
    {
        int x1,y1,x2,y2;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='Y')
                    x1=i,y1=j;
                else if(a[i][j]=='M')
                    x2=i,y2=j;
            }
        }
        memset(dis,0x3f3f3f3f,sizeof(dis));
        BFS(0,x1,y1);
        BFS(1,x2,y2);
        int ans=0x3f3f3f3f;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='@')
                {
                    ans=min(ans,dis[0][i][j]+dis[1][i][j]);
                }
            }
        }
        cout<<ans*11<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值