2014ACM/ICPC亚洲区北京站

2014ACM/ICPC亚洲区北京站(HDU5112-5122)

(以下题目描述摘自UVA LIVE)

H题

题目描述

Matt has N friends. They are playing a game together.
Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his
friends. If the xor (exclusive-or) sum of the selected friend’s magic numbers is no less than M, Matt
wins.
Matt wants to know the number of ways to win.
Input
The first line contains only one integer T, which indicates the number of test cases.
For each test case, the first line contains two integers N, M (1 N 40, 0 M 106).
In the second line, there are N integers ki (0 ki 106), indicating the i-th friend’s magic number.
Output
For each test case, output a single line ‘Case #x: y’, where x is the case number (starting from 1) and
y indicates the number of ways where Matt can win.
Hint: In the first sample, Matt can win by selecting:
• friend with number 1 and friend with number 2. The xor sum is 3.
• friend with number 1 and friend with number 3. The xor sum is 2.
• friend with number 2. The xor sum is 2.
• friend with number 3. The xor sum is 3. Hence, the answer is 4.
Sample Input
23
2
1 2 3
3 3
1 2 3
Sample Output
Case #1: 4
Case #2: 2

题意

给N个数,问有多少种组合,使他们的异或和大于M。

解法

注意到每个数和M小于10^6,异或和最大为2^20-1,就应该想到DP!
dp[i][j]表示对于前i个数,表示异或和为j的组合数。显示第一维可以滚动数组。

#include<cstdio>
#include<cstring>

using namespace std;

int N, M;
typedef long long ll;
const int SIZE = 1 << 20 - 1;
ll dp[2][1 << 20];

int main(){
    int T;
    scanf("%d",&T);
    for(int cs = 1; cs <= T; cs++){
        scanf("%d %d",&N,&M);
        int now = 0, otr;
        memset(dp[now],0,sizeof(dp[now]));
        dp[0][0] = 1;
        for(int i = 1; i <= N; i++){
            int a;
            scanf("%d",&a);
            otr = now;
            now = i & 1;
            memset(dp[now],0,sizeof(dp[now]));
            for(int j = 0; j <= SIZE; j++){
                dp[now][j ^ a] += dp[otr][j];
                dp[now][j] += dp[otr][j];
            }
        }
        ll res = 0;
        for(int i = M; i <= SIZE; i++) res += dp[now][i];
        printf("Case #%d: %lld\n",cs,res);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值