SWUST OJ 之 0676 Piggy-Bank

这篇博客介绍了一个ACM预算问题,涉及如何通过称重预测存钱罐(Piggy-Bank)中的最低金额。这是一个动态规划问题,目标是在满足存钱罐重量限制的同时找到最小价值。文章通过分析和模拟,提出了一种根据硬币重量和价值确定存钱罐内最低金额的算法策略。
摘要由CSDN通过智能技术生成

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

输入

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

输出

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the 
piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the 
weight cannot be reached exactly, print a line "This is impossible.". 

样例输入

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

样例输出

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

分析

这是个动态规划问题(题目自己翻译o(╯□╰)o~~),题目最终要我们得出的是在“满足承受重量”的同时“得到最小价值”;

 

首先,求出存钱罐可以承受的重量 wight = full - empty ; 
接下来会给出硬币的种类数量 n ;

 

下面 n 行每行给出硬币的价值 P 和重量 W ;

 

我们先创建一个全局数组 dp[MAX] , MAX 是定义的一个常量(#define MAX 10005)这里我们要开大一点;
其中“数组下标 i ”代表此时硬币总重量,“数组元素值 dp[i] ”代表重量为 i 时的价值量;

 

初始化数组 dp[0] = 0,dp[1~MAX] = INF ,INF为一个常量(#define INF 0x3f3f3f3f),即 INF = 十进制 1061109567;

现在我们来思考模拟一下每单独放入一个同种货币时,存钱罐中的价值和重量的变化:

① dp[0] = 0;                          dp[1] = INF                               dp[2] = INF                               …………

② dp[0+W] = dp[0]+P;         dp[1+W] = dp[1]+P;               dp[2+W] = dp[2]+P;             …………

③ dp[0+2W] = dp[W]+P;     dp[1+2W] = dp[1+W]+P;       dp[2+2W] = dp[2+W]+P;      …………

我们可以看出数组下标(重量)和数组元素值(价值)呈现一定的规律性,所以我们可以总结出以下结论:
当数组下标(重量)从有一个硬币开始(没有硬币时价值为0),dp[ i ] = dp[i - W]+P,从 i = W 到 i = wight;
因为有多种硬币,每次都要这样循环,所以 dp[ i ] = min{dp[i - W]+P,dp[ i ]};

最后根据 dp[wight] 的值是否为 INF 来判断是否有解,这样我们就有了一个解题思路;

代码

// Test.cpp: 定义控制台应用程序的入口点。
//

#include<iostream>
#include<stdio.h>
#include<algorithm>
#define INF 0x3f3f3f3f
int dp[10005];
using namespace std;

int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int empty, full;		
		cin >> empty >> full;		
		int weight = full - empty;		//真实可以使用的重量
		for (int i = 1; i <= weight; i++)
			dp[i] = INF;
		dp[0] = 0;				//元素值为最小价值
		int n;
		cin >> n;
		while (n--)
		{
			int P, W;
			cin >> P >> W;
			for (int i = W; i <= weight; i++)
			{
				dp[i] = min(dp[i], dp[i - W] + P);	//每次取最小值---最优迭代解
			}
		}
		if (dp[weight] == INF)			//没有解
			cout << "This is impossible." << endl;
		else
			cout << "The minimum amount of money in the piggy-bank is "
			<< dp[weight] << "." << endl;
	}

	return 0;
}

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值