SDUT 3338 计算各种图形的周长

计算各种图形的周长(接口与多态)

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
定义接口Shape,定义求周长的方法length()。
定义如下类实现接口Shape的抽象方法:
(1)三角形类Triangle (2)长方形类Rectangle (3)圆形类Circle等。
定义测试类ShapeTest,用Shape接口定义变量shape,用其指向不同类形的对象,输出各种图形的周长。并为其他的Shape接口实现类提供良好的扩展性。
Input
输入多组数值型数据(double);
一行中若有1个数,表示圆的半径;
一行中若有2个数(中间用空格间隔),表示长方形的长度、宽度。
一行中若有3个数(中间用空格间隔),表示三角形的三边的长度。
 
若输入数据中有负数,则不表示任何图形,周长为0。
Output
行数与输入相对应,数值为根据每行输入数据求得的图形的周长(保留2位小数)。
Example Input
1
2 3
4 5 6
2
-2
-2 -3
Example Output
6.28
10.00
15.00
12.56
0.00

0.00

import java.text.DecimalFormat;
import java.util.Scanner;

class rectangle {
	double x, y, z, x1, y1, z1;

	public rectangle(double x1, double y1, double z1) {
		this.x1 = x1;
		this.y1 = y1;
		this.z1 = z1;
	}

	public rectangle(double x1, double y1) {
		x = x1;
		y = y1;
	}

	public rectangle(double x1) {
		z = x1;
	}

	double area() {
		return z * 2 * 3.14;
	}

	double area1() {
		return (x + y) * 2;
	}

	double area2() {
		return x1 + y1 + z1;
	}
};

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			DecimalFormat two = new DecimalFormat("#0.00");
			String str = sc.nextLine();
			String[] strs = str.split(" ");
			int[] a = new int[100];
			int i;
			for (i = 0; i < strs.length; i++) {
				a[i] = Integer.parseInt(strs[i]);
			}
			int x, y, z;
			if (i == 1) {
				x = a[0];
				if (x <= 0) {
					System.out.println("0.00");
				} else {
					rectangle d = new rectangle(x);
					System.out.println(two.format(d.area()));

				}
			} else if (i == 2) {
				x = a[0];
				y = a[1];
				if (x <= 0) {
					System.out.println("0.00");
				} else {
					rectangle d = new rectangle(x, y);
					System.out.println(two.format(d.area1()));

				}
			} else if (i == 3) {
				for (i = 0; i < 3; i++) {
					for (int j = 0; j < i; j++) {
						if (a[j] > a[j + 1]) {
							int max = a[j];
							a[j] = a[j + 1];
							a[j + 1] = max;
						}
					}
				}
				x = a[0];
				y = a[1];
				z = a[2];
				if (x + y > z) {
					if (x <= 0) {
						System.out.println("0.00");
					} else {
						rectangle d = new rectangle(x, y, z);
						System.out.println(two.format(d.area2()));

					}
				}
				else {
					System.out.println("0.00");
				}
			}
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值