【PAT刷题甲级】1059.Prime Factors

1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1×p2 ^k2×⋯×pm ^km.

Input Specification

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification

Factor N in the format
在这里插入图片描述
where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi-- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input

97532468

Sample Output

97532468=2^2*11*17*101*1291

题意

输入一串长数,输出其质因子的乘积形式,多个相同质因子用其幂的形式表示。
注意第4个测试点为特殊点1,需要单独讨论。

代码

#include <iostream>
#include <map>
#include <cmath>
using namespace std;
map<long int,long int> p;
bool isprime(long int n) {		//判断素数
	if(n<=1)	return false;
	long int sqr=(long int)sqrt(1.0*n);
	for(long int i=2; i<=sqr; i++) {
		if(n%i==0)	return false;
	}
	return true;
}
int main() {
	long int n;
	scanf("%ld",&n);
	printf("%ld=",n);
	if(n==1)	printf("1");
	for(long int i=2; i<=n;) {
		if(isprime(i)!=0 && n%i==0) {
			n=n/i;
			p[i]++;
		} else {
			i++;
		}
	}
	for(auto it=p.begin(); it!=p.end();) {
		printf("%ld",it->first);
		if(it->second!=1)	printf("^%ld",it->second);
		if(++it!=p.end())	printf("*");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值