【PAT刷题甲级】1086.Tree Traversals Again

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1

Figure 1

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output

3 4 2 6 5 1

题意

根据先序序列和中序序列输出后序序列。

代码

#include <iostream>
#include <vector>
using namespace std;
vector<int> v,pre,in,post;
int n,t;	//结点总数,结点值 
void topost(int is,int ie,int ps,int pe) {	//根据先序和中序输出后序(中序起始位置,中序结束位置,先序起始位置,先序结束位置)
	post[--n]=pre[ps];						//倒着存,应该是根右左的顺序
	int i=0;
	while(i<ie && in[i]!=pre[ps])	i++;
	if(ie-i>0)	topost(i+1,ie,i-is+1+ps,pe);	//如果存在右子树,先存右节点
	if(i-is>0)	topost(is,i-1,ps+1,i-is+ps);	//如果存在左子树,存左节点
}
int main() {
	scanf("%d",&n);
	string s;	//操作名称
	post.resize(n);
	for(int i=0; i<2*n; i++) {
		cin >> s;
		if(s=="Push") {
			scanf("%d",&t);
			pre.push_back(t);
			v.push_back(t);
		} else {
			in.push_back(v[v.size()-1]);
			v.pop_back();
		}
	}
	topost(0,n-1,0,n-1);
	for(auto it=post.begin(); it!=post.end();) {
		printf("%d",*it);
		if(++it!=post.end())	printf(" ");
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值