【PAT刷题甲级】1115.Counting Nodes in a BST

1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input

9
25 30 42 16 20 20 35 -5 28

Sample Output

2 + 4 = 6

题意

给定N个数字,创建一棵二叉排序树(BST)。输出最后两层的结点数。(可用层序遍历计算层号,用二维数组存放每一层的结点)

代码

#include <iostream>
#include <vector>
#include <queue>
#include <cmath>	//用于max函数 
using namespace std;
int n,t,maxlayer;
vector<int> cnt[1001];	//cnt用于存放BST每一层节点的数值
struct node {
	int data,layer;		//数据域,层号
	node *left,*right;	//指针域
};
void insert(node* & root,int data) {	//BST插入节点
	if(root==NULL) {
		root = new node;
		root->data=data;
		root->left=root->right=NULL;
		return;
	}
	if(data<=root->data)	insert(root->left,data);
	else	insert(root->right,data);
}
void layOrder(node *root) {	//层序遍历
	queue<node*> q;			//队列中存的是地址
	root->layer=1;
	cnt[root->layer].push_back(root->data);
	q.push(root);
	while(!q.empty()) {
		node *now=q.front();
		maxlayer=max(now->layer,maxlayer);
		q.pop();
		if(now->left!=NULL) {
			now->left->layer = now->layer + 1;
			cnt[now->left->layer].push_back(now->left->data);
			q.push(now->left);
		}
		if(now->right!=NULL) {
			now->right->layer = now->layer + 1;
			q.push(now->right);
			cnt[now->right->layer].push_back(now->right->data);
		}
	}
}
int main() {
	scanf("%d",&n);
	node* root=NULL;	//定义头结点
	for(int i=0; i<n; i++) {
		scanf("%d",&t);
		insert(root,t);
	}
	layOrder(root);
	int n1=cnt[maxlayer].size();
	int n2=cnt[maxlayer-1].size();
	printf("%d + %d = %d",n1,n2,n1+n2);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值