PAT-甲级-1115 Counting Nodes in a BST (30 分)

60 篇文章 0 订阅

1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题目大意:给定一个序列,建立一棵BST(二叉搜索树),要求输出最后两层结点数之和。

解题思路:

  • 因为BST是一个动态建树的过程,所以要在每次输入一个结点时,动态的调整结点,在调完结点之后还要将指针返回,所以建树的BST函数有一个node*返回值;
  •  建完树之后,dfs计算每个深度的结点个数,最后输出即可。
#include <iostream>
#include <vector>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
struct node{
    int d;
    struct node *l,*r;
};
node* BST(node *u,int d){
    if(u==NULL){
        u = new node();
        u->d = d;
        u->l = u->r = NULL;
    }else if( d <= u->d)
        u->l =  BST(u->l,d);
    else
        u->r =  BST(u->r,d);
    return u;
}
vector<int> v(1000);
int maxDep = -1;
void dfs(node *u,int dep){
    if(u==NULL){
        maxDep = max(maxDep,dep);
        return;
    }
    v[dep]++;
    dfs(u->l,dep+1);
    dfs(u->r,dep+1);
}
int main(){
    std::ios::sync_with_stdio(false);
    int n,d;
    node *root = NULL;
    cin>>n;
    rep(i,0,n){
        cin>>d;
        root = BST(root,d);
    }
    dfs(root,0);
    printf("%d + %d = %d",v[maxDep-1],v[maxDep-2],v[maxDep-1]+v[maxDep-2]);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值