【PAT刷题甲级】1111.Online Map

1111 Online Map (30 分)

Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.

Input Specification

Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:

V1 V2 one-way length time

where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.

Finally a pair of source and destination is given.

Output Specification

For each case, first print the shortest path from the source to the destination with distance D in the format:

Distance = D: source -> v1 -> ... -> destination

Then in the next line print the fastest path with total time T:

Time = T: source -> w1 -> ... -> destination

In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.

In case the shortest and the fastest paths are identical, print them in one line in the format:

Distance = D; Time = T: source -> u1 -> ... -> destination

Sample Input 1

10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5

Sample Output 1

Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5

Sample Input 2

7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5

Sample Output 2

Distance = 3; Time = 4: 3 -> 2 -> 5

题意

两次运用Dijkstra+DFS,分别求最短距离和最快时间。
PS:之前测试点2,4怎么都通不过,后来才发现是Dijkstra代码中else if的括号对应错误,写代码一定要仔细,不然找bug很难,也不知道问题出在哪里,从昨晚到现在才找出这个错误o(╥﹏╥)o

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int n,m,st,ed,G[510][510],T[510][510];	//G存放距离,T存放时间
int t[510],d[510];	 		//存最短时间和最短距离
int pret[510],pred[510];	//记录前驱结点
vector<int> pt,pd;			//存放最快时间路径和最短距离路径
int num[510];	   			//标记使用的点
bool vis[510];	   			//标记节点是否被访问
const int inf=0x3fffffff;
void Dijkstra1(int st) {
	fill(d,d+510,inf);
	fill(t,t+510,inf);
	for(int i=0; i<n; i++) {
		pred[i]=i;
	}
	d[st]=0;
	for(int i=0; i<n; i++) {
		int u=-1,minn=inf;
		for(int j=0; j<n; j++) {
			if(vis[j]==false && d[j]<minn) {
				u=j;
				minn=d[j];
			}
		}
		if(u==-1)	return;
		vis[u]=true;
		for(int v=0; v<n; v++) {
			if(vis[v]==false && G[u][v]!=inf) {
				if(d[u]+G[u][v]<d[v]) {
					d[v]=d[u]+G[u][v];
					pred[v]=u;
					t[v]=t[u]+T[u][v];
				} else if(d[u]+G[u][v]==d[v] && t[u]+T[u][v]<t[v]) {
					t[v]=t[u]+T[u][v];
					pred[v]=u;
				}
			}
		}
	}
}
void Dijkstra2(int st) {
	fill(t,t+510,inf);
	fill(vis,vis+510, false);
	for(int i=0; i<n; i++) {
		pret[i]=i;
	}
	t[st]=0;
	for(int i=0; i<n; i++) {
		int u=-1,minn=inf;
		for(int j=0; j<n; j++) {
			if(vis[j]==false && t[j]<minn) {
				u=j;
				minn=t[j];
			}
		}
		if(u==-1)	return;
		vis[u]=true;
		for(int v=0; v<n; v++) {
			if(vis[v]==false && T[u][v]!=inf) {
				if(t[u]+T[u][v]<t[v]) {
					t[v]=t[u]+T[u][v];
					pret[v]=u;
					num[v]=num[u]+1;
				} else if(t[u]+T[u][v]==t[v] && num[u]+1<num[v]) {
					pret[v]=u;
					num[v]=num[u]+1;
				}
			}
		}
	}
}
void DFS(int v,int sig) {
	if(sig==0) {
		pd.push_back(v);
		if(v==st)	return;
		DFS(pred[v],0);
	}
	if(sig==1) {
		pt.push_back(v);
		if(v==st)	return;
		DFS(pret[v],1);
	}
}
int main() {
	scanf("%d %d",&n,&m);
	fill(G[0],G[0]+510*510,inf);
	fill(T[0],T[0]+510*510,inf);
	int a,b,ow,dis,cc;
	for(int i=0; i<m; i++) {
		scanf("%d %d %d %d %d",&a,&b,&ow,&dis,&cc);
		G[a][b]=dis;
		T[a][b]=cc;
		if(ow==0) {
			G[b][a]=dis;
			T[b][a]=cc;
		}
	}
	scanf("%d %d",&st,&ed);
	Dijkstra1(st);
	DFS(ed,0);
	Dijkstra2(st);
	DFS(ed,1);
	if(pd==pt) {
		printf("Distance = %d; Time = %d: ",d[ed],t[ed]);
		for(int j=pd.size()-1; j>=0; j--) {
			printf("%d",pd[j]);
			if(j!=0)	printf(" -> ");
		}
	} else {
		printf("Distance = %d: ",d[ed]);
		for(int j=pd.size()-1; j>=0; j--) {
			printf("%d",pd[j]);
			if(j!=0)	printf(" -> ");
		}
		printf("\n");
		printf("Time = %d: ",t[ed]);
		for(int j=pt.size()-1; j>=0; j--) {
			printf("%d",pt[j]);
			if(j!=0)	printf(" -> ");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值