【PAT(甲级)】1072 Gas Station

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10^{3}), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10^{4}), the number of roads connecting the houses and the gas stations; and DS​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

解题思路:

最短路径问题,用Dijisktra算法就可以解题。需要注意的是,起点应该是加油站的位置,也就是说,每个加油站都要用Dijisktra算法走一遍,看一下是否能到达每个居民点,所以要注意在使用算法时的一些变量需要重置。

对加油站Gn只要换算成N+n即可,这样可以方便运算。

易错点:

1. 测试样例1中的3.3是个错误数据,真实答案应该是3.2,算出来的数据不需要四舍五入。

2. 最后一个测试点是数组容量的问题,最大应该是N+M,最大不超过1010个。

代码:

#include<bits/stdc++.h>
using namespace std;

int N;//房子总数
int M;//加油站总数
int K;//路的总数
int D;//加油站的最大服务范围 
const int INF = 10000000;
double mindistance = 0;
int minnode = -1;
double ave = 999999;
int road[1011][1011];//测试点4,M+N最大有1010

// 因为不止一个加油站地点,所以访问的visit数组要定义在Dijsktra函数里,方便重置 
void Dijsktra(int g){
	int visit[1011] = {0};
	int dist[1011];
	fill(dist,dist+1011,INF);
	dist[g] = 0;
	for(int i = 0;i < N+M;i++){//走遍所有加油站和房子 
		int min = INF,flag = -1;
		for(int j = 1;j <= N+M;j++){
			if(visit[j] == 0&&dist[j] < min){
				flag = j;
				min = dist[j];
			}
		}
		if(flag == -1) break;
		visit[flag] = 1;
		for(int j = 1;j <= N+M;j++){
			if(!visit[j] && road[flag][j] != INF){
				if(dist[flag]+road[flag][j]<dist[j]){
					dist[j] = dist[flag]+road[flag][j];
				}	
			}
		}
	}
	int min = INF;
	double sum = 0;
	for(int i=1;i<=N;i++){
		if(dist[i]<min){
			min = dist[i];
		}
		sum+=1.0*dist[i];
		if(dist[i]>D) return;
	}
	if((min > mindistance)||(min == mindistance&&sum/N < ave)){
		mindistance = min;
		ave = sum/N;
		minnode = g;
	}
}

int turn(string a){
	return a[0]=='G'? N+stoi(a.substr(1,a.length()-1)):stoi(a);
}

void read(int a){
	for(int i=0;i<a;i++){
		string t1,t2,t3;
		cin>>t1>>t2>>t3;
		road[turn(t1)][turn(t2)] = turn(t3);
		road[turn(t2)][turn(t1)] = turn(t3);
	}
}

int main(){
	fill(road[0],road[0]+1011*1011,INF);
	cin>>N>>M>>K>>D;
	read(K);
	for(int i=N+1;i<=N+M;i++){
		Dijsktra(i);
	}
	if(minnode == -1) cout<<"No Solution";
	else{
		printf("G%d\n",minnode-N);
		printf("%.1f %.1f",mindistance,ave);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值