【PAT刷题甲级】1097.Deduplication on a Linked List

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10 ^5 ) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10 ^4 , and Next is the position of the next node.

Output Specification

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题意

将绝对值相同的数只保留第一次出现的,剩下的去除放至新链表中。要求输出去除多余数后的链表和存放多余数的链表(注意可能不存在多余数)。

代码

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
struct node {
	int add,data,next;
} Node[100010];
bool book[10000];
int main() {
	int t,n,a;
	scanf("%d%d",&t,&n);
	for(int i=0; i<n; i++) {
		scanf("%d",&a);
		Node[a].add=a;
		scanf("%d%d",&Node[a].data,&Node[a].next);
	}
	vector<node> v,r;
	int p=t;
	while(p!=-1) {
		int tmp=abs(Node[p].data);
		if(book[tmp]==false) {
			v.push_back(Node[p]);
			book[tmp]=true;
		} else {
			r.push_back(Node[p]);
		}
		p=Node[p].next;
	}
	for(int i=0; i<v.size(); i++) {
		if(i==0)	printf("%05d %d ",v[i].add,v[i].data);
		else {
			printf("%05d\n%05d %d ",v[i].add,v[i].add,v[i].data);
		}
	}
	printf("-1\n");
	if(r.size()>0) {
		for(int i=0; i<r.size(); i++) {
			if(i==0)	printf("%05d %d ",r[i].add,r[i].data);
			else {
				printf("%05d\n%05d %d ",r[i].add,r[i].add,r[i].data);
			}
		}
		printf("-1");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值