【算法题】UVA369 Combinations(组合数)

题目
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N
Compute the EXACT value of: C = N! / (N-M)!M!

输入
The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

输出
The output from this program should be in the form:
N things taken M at a time is C exactly.

Sample Input
100 6
20 5
18 6
0 0

Sample Output
100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.

提示:
大数的计算,用double。

#include<iostream>
#include<cstdio>
using namespace std;  
  
int main()  
{  
    int N, M;  
    while (scanf("%d%d",&N,&M) && (N||M)){  
        double C = 1;  // 注意是double !!
        for (int i=N;i>N-M;i--) 
			C *= i;  
        for (int i=1;i<=M;i++) 
			C /= i;  
		printf("%d things taken %d at a time is %.0f exactly.\n",N,M,C);
    }  
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值