hdoj-1260


Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3268    Accepted Submission(s): 1619


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 

Sample Output
  
  
08:00:40 am 08:00:08 am
 

Source

题意很简单理解  一个人卖票,想早点回家,他可以一次卖1张票,也可以选择一次卖2张票
求最早能什么时候回家  自己想了好长时间都不会,看网上的都说是简单dp,(你们是在坑我吗??)同志们
一点都不简单,还是自己太菜,最最核心的已经注释,自己慢慢理解吧


#include<cstdio>
#include<cstring>
int dp[2500];
int a[2500],b[2500];
int min(int x,int y)
{
	if(x<y)
		return x;
	return y;
}

int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		memset(dp,0,sizeof(dp));
		int k;
		scanf("%d",&k);
		for(int i=1;i<=k;++i)
			scanf("%d",&a[i]);
		for(int i=2;i<=k;++i)
			scanf("%d",&b[i]);
		dp[1]=a[1];
		for(int i=2;i<=k;++i)
			dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);//主要就是这个公式
		 int h,m,s;
		 h=dp[k]/3600;
		 m=(dp[k]-h*3600)/60;
		 s=dp[k]-h*3600-m*60;
		 int sh=8;
		 h+=sh;
		 if(h>12)
		 	printf("%02d:%02d:%02d pm\n",h-12,m,s);
		else
			printf("%02d:%02d:%02d am\n",h,m,s);
	}
	return 0; 
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值