Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am

题目意思为去火车站买票,每次可以单独买或者与相邻的两个当中一个一起买,给出单独买和两个人一起买的价格,求最小的买票时间,但是题目要求最早回去,所以要从八点开始,用八点的秒数加上买票的时间,最后判断是否过了中午12点,如果过了用pm标出,否则用am,本题对于每一个人,都有两种决策,单独买或者一起买,一起买时,与后面的人一起买,可以等到轮到后面那个人时与前面的人一起买的那个状态重合,所以只需要考虑和前面的人一起买还是单独买。所以可以得出状态转移方程

dp[i] = min(dp[i-1]+a[i], dp[i-2]+b[i]);dp[i]表示前i个人的最优值。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn = 2000 + 10;
const int halfday = 12*60*60;
int a[maxn], b[maxn], dp[maxn];
int main()
{
    int T;
    cin >> T;
    while(T --)
    {
        int n;
        cin >> n;
        memset(dp, 0, sizeof(dp));
        memset(a, maxn, sizeof(a));
        memset(b, maxn, sizeof(b));
        for(int i = 1; i <= n; i ++)
        {
            cin >> a[i];
        }
        for(int i = 2; i <= n; i ++)
        {
            cin >> b[i];
        }
        dp[1] = a[1];
        for(int i = 2; i <= n; i ++)
        {
            dp[i] = min(dp[i-1]+a[i], dp[i-2]+b[i]);
        }
        int ans = dp[n];
        ans += 8*3600;
        int flag = ans / halfday;
        if(flag)
        {
            ans -= halfday;
            int h = ans / 3600;
            ans %= 3600;
            int m = ans / 60;
            ans %= 60;
            printf("%02d:%02d:%02d pm\n", h, m, ans);
        }
        else
        {
            int h = ans / 3600;
            ans %= 3600;
            int m = ans / 60;
            ans %= 60;
            printf("%02d:%02d:%02d am\n", h, m, ans);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值