poj-【2115 C Looooops】

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24017 Accepted: 6654

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766

FOREVER

题意 for(i=a;i!=b,i+=c) 输入a,b,c,k代表多少位,就是i的最大值为2的k次方 刚开始并没有看出来与拓展欧几里得有关,看到网上的发现了一个新的知识 对于电脑所有的数据都是按照二进制来进行存放的,比如一个二进制数  11111111如果再加上1就会变成100000000 当时对于k为,最高位的就会别舍去,结果编程了0,i又会重新开始。 好了,估计大家就会懂了,现在开始进行公式的推导 发现如果第一次i!=b,然后从0开始就这样循环下去假设for循环循环了x次 (a+c*x)%2^k=b; -> (a+c*x)/(2^k)=y......b 化简  y*(2^k)+b=a+c*x ->  c*x+y*(2^k)=b-a; 哈哈出来了,赶快写属于自己的程序吧 

<span style="font-size:18px;">#include<cstdio>
#define LL __int64
void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(b==0)
	{
		d=a;
		y=0;
		x=1;
	} 
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=x*(a/b); 
	} 
} 
int main()
{
	LL a,b,c,k;
	while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k)!=EOF&&(a+b+c+k!=0))
	{
		LL d,b1=(LL)1<<k,c1=b-a,a1=c,x,y;//一定要加上强制转换 
		exgcd(a1,b1,d,x,y);
		if(c1%d)
		{
			printf("FOREVER\n"); 
		} 
		else
		{
			b1/=d;
			x=(x*(c1/d))%b1;
			LL ans=(x+b1)%b1;
			printf("%I64d\n",ans); 
		} 
	} 
	return 0;
} 
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值