POJ 2115 C Looooops

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17676 Accepted: 4580

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

CTU Open 2004


题意:和青蛙的约会差不多,大体意思是给出一个变量A,然后看加多少次C后能等于B,且每次要对2^k取余,得出公式:A+Cx=B%(2^k),整理得Cx+2^k*y=B-A;(y=B/(2^k))然后跟青蛙的约会差不多的做法

#include <iostream>
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
__int64 gcd(__int64 a,__int64 b)
{
    return b==0?a:gcd(b,a%b);
}
void Gcd(__int64 a,__int64 b,__int64 &d,__int64 &x,__int64 &y)
{
    if(!b)
    {
        d=a;
        x=1;
        y=0;
    }
    else
    {
        Gcd(b,a%b,d,y,x);
        y=y-x*(a/b);
    }
}
int main()
{
    __int64 A,B,C,k,a,b,c,d,s,t,x,y;
    while(scanf("%I64d%I64d%I64d%I64d",&A,&B,&C,&k))
    {
        if(A==0&&B==0&&C==0&&k==0)//把这句放在while循环里WA了,原因不明
        break;
        a=C;
        b=(__int64)1<<k;
        c=B-A;
        s=gcd(a,b);
        if(c%s!=0)
        {
            printf("FOREVER\n");
        }
        else
        {
            a=a/s;
            b=b/s;
            c=c/s;
            Gcd(a,b,d,x,y);
            x=c*x%b;
            if(x<0)
                x=x+b;
            printf("%I64d\n",x);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值