poj-【2891 Strange Way to Express Integers】

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 14314 Accepted: 4642

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (ai,ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

题目很难搞懂 拿样例说一下吧
2 代表有2组数据 
8 7  x=7(mod 8) 
11 9 x=9(mod 11) 
求最小的 x 的值 

<span style="font-size:18px;">#include<cstdio>
#define LL long long
void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(b==0)
	{
		y=0;x=1;
		d=a;
	} 
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=x*(a/b); 
	} 
} 
int main()
{
	int T;
	while(scanf("%d",&T)!=EOF)
	{
		LL a1,r1,i,flag=0,a2,r2,k1,k2,d,c,t,x1;
		scanf("%lld%lld",&a1,&r1);
		if(T==1)
		{
			if(a1<=r1)
				printf("-1\n");
			else
				printf("%lld\n",r1);
			continue; 
		} 
		for(i=1;i<T;++i)
		{
			scanf("%lld%lld",&a2,&r2);//r2是余数 
			if(flag)
				continue; 
			c=r2-r1;
			exgcd(a1,a2,d,k1,k2);
			if(c%d)
			{
				flag=1;
				//break;
			}
			x1=k1*c/d;
			t=a2/d;
			x1=(x1%t+t)%t;
			r1+=x1*a1;
			a1=a1/d*a2; 
		}
		if(flag)
			printf("-1\n"); 
		else
			printf("%lld\n",r1);		
	} 
	return 0;
} </span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值