HDOJ-【1016 Prime Ring Problem】

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44390    Accepted Submission(s): 19676


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

最近要刷DFS,BFS的题目这是第二道题目,自己写出来的,很高兴
好好想想你就会了

#include<cstdio>
#include<cstring>
int prime[30];
int ans[30],vis[30],n,tag,test; 
void Init()
{
	int i,j;
	for(i=0;i<25;++i)
		prime[i]=0;
	prime[0]=prime[1]=1; 
	for(i=2;i<25;++i)
	{
		for(j=2*i;j<25;j+=i)
			prime[j]=1; 
	} 
}
void dfs(int r,int pos)
{
	if(pos==n&&!prime[r+1])
	{
		if(tag) 
			printf("Case %d:\n",test); 
		for(int i=0;i<n-1;++i)
			printf("%d ",ans[i]); 
		printf("%d\n",ans[n-1]); 
		tag=0; 
	}
	for(int j=2;j<=n;++j)
	{
		if(!prime[r+j]&&!vis[j])
		{
			ans[pos]=j;
			vis[j]=1;
			dfs(j,pos+1);
			vis[j]=0; 
		} 
	} 
} 
int main()
{
	test=0;
	Init(); 
	while(~scanf("%d",&n))
	{
		tag=1;
		++test;
		memset(vis,0,sizeof(vis)); 
		ans[0]=1;
		dfs(1,1);
		printf("\n"); 
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值