HDoj-1016-Prime Ring Problem-DFS

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27754    Accepted Submission(s): 12338


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include<cstdio>
#include<cstring>
int n;
int prime[30]={1,1,0};
int way[30];    //存储最后结果序列
int visit[30];  //vis表示是否访问
void isprime() //不是素数标记为1 
{
	int i,j;
	for(i=2;i<30;i++)
	{
		for(j=2*i;j<30;j+=i)
		{
			prime[j]=1;
		}
	}
}
void dfs(int temp)  //环当前位置 
{
	int i;
	if(temp==n && prime[way[0]+way[n-1]]==0)//若到达边界且首尾两个数字相加满足素数
	{
		for(i=0;i<n-1;i++)//打印方案
		{
			printf("%d ",way[i]);
			
		}
		printf("%d\n",way[i]); 
	}
	else
	{
		for(i=2;i<=n;i++)
		{
			if(visit[i]==0 && prime[i+way[temp-1]]==0)  //i没有访问过且与前一个数相加为素数
			{
				way[temp]=i;
				visit[i]=1;   //表示i访问过 
				dfs(temp+1);
				visit[i]=0;   //i不满足条件, 之前做的标记要修改 
			}
		}
	}
}
int main()
{
	int count=1;
	memset(visit,0,sizeof(visit));
	//memset(way,0,sizeof(way));
	way[0]=1;
	isprime();
	while(~scanf("%d",&n))
	{
		printf("Case %d:\n",count++);
		dfs(1);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值