hdoj-【1072 Nightmare】

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10282    Accepted Submission(s): 5016


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1

13

好长时间没有写bfs,结果竟然是用队列,(一直认为是栈); 其实bfs的原理就是以出发点为圆心向外画同心圆,直到找到终点,这样找 肯定是最短距离,主要还是如何控制没有意义的行走,其实很简单就是记录 经过这个点的time的最大值,当再次达到这个点时;比较一下, 如果当前点剩余的时间小于那肯定没有任何意义在走下去了,因为无论你怎么 走都不可能更远了, 如果大于那肯定可以,并更新时间(我也是看了别人的思路和代码)

#include<cstdio>
#include<queue>
using namespace std;
int map[20][20],n,m,flag;
int vis[20][20],ex,ey,c;
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1}; 
struct node                                                           
{
	int tx,ty;
	int temp;
	int g;
};
void bfs(int x,int y)
{
	queue<node>que;
	node s;
	s.tx=x;s.ty=y;
	s.temp=6;
	s.g=0;
	vis[x][y]=6; 
	que.push(s);
	while(!que.empty())
	{
		node tmp;
		tmp=que.front();
		que.pop();
		if(tmp.tx==ex&&tmp.ty==ey)
		{
			c=tmp.g;
			flag=1;
			return ;
		} 
		if(tmp.temp==1)
			continue;
		for(int i=0;i<4;++i)
		{
			node h;
			h.tx=tmp.tx+dx[i];
			h.ty=tmp.ty+dy[i];
			h.temp=tmp.temp-1;
			if(map[h.tx][h.ty]!=0&&h.tx>=0&&h.tx<n&&h.ty>=0&&h.ty<m)
			{
				h.g=tmp.g+1;
				if(map[h.tx][h.ty]==4)
					h.temp=6;
				if(h.temp>vis[h.tx][h.ty])
				{
					vis[h.tx][h.ty]=h.temp;
					que.push(h); 
				} 
			} 
		} 
	} 
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		flag=0;
		scanf("%d%d",&n,&m);
		int i,j,sx,sy;
		for(i=0;i<n;++i)
		{
			for(j=0;j<m;++j)
			{
				scanf("%d",&map[i][j]); 
				if(map[i][j]==2)
					sx=i,sy=j;
				if(map[i][j]==3) 
					ex=i,ey=j;
				vis[i][j]=0; 
			} 
		}
		bfs(sx,sy);
		if(flag)
			printf("%d\n",c);
		else
			printf("-1\n"); 
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值