HDOJ 1072 Nightmare(BFS)

Nightmare




Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13
题目大意: Ignatius晚上做了一个噩梦,他发现自己被困在一个迷宫里,身上绑了一个定时炸弹。初始时炸弹上的计时器显示还有6分钟,他必须在计时器归零之前到达出口。为了防止炸弹爆炸,他每分钟只能移动一格,方向为上下左右其中的一个。幸运的是,迷宫里有时间重置器,可以将定时炸弹的计时器重置为6。请求出 Ignatius逃出迷宫所需要的最短时间,否则输出-1。规则如下

(1)迷宫是2维的

(2)每分钟Ignatius只能走一格,他不能走出边界,当然,他也不能在墙上走

(3)如果当Ignatius走到出口时计时器刚好归零,那么他不能逃出迷宫

(4)如果当Ignatius走到时间重置器时计时器刚好归零,那么他来不及使用时间重置器

(5)时间重置器可以被多次使用。如果需要的话,你可以让Ignatius走到任何你想让他到达的地方

(6)使用时间重置器的时间可以忽略不计。换句话说,如果Ignatius走到了一个含有时间重置器的格子并且计时器上的数字大于0,那么计时器会瞬间重置为6

输入为一个n * m的矩阵,其中0代表墙,1代表路,2代表Ignatius的起始位置,3代表出口,4代表时间重置器。

解题思路:使用一个三维数组保存每个点的状态,如果某次到达某个点的剩余时间与上一次到达这一点的剩余时间相同,就可以不用将该点入队。

代码如下:

#include <algorithm>
#include <cctype>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <string>
#include <vector>
#define EPS 1e-6
#define INF INT_MAX / 10
#define L l,m,rt << 1
#define LL long long
#define MEM(arr,val) memset(arr,val,sizeof(arr))
#define MOD 100000000
#define PI acos(-1.0)
#define R m + 1,r,rt << 1 | 1
using namespace std;
struct node
{
    int x,y;
    int time;
};
int dir[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};
int sx,sy,ex,ey;
int maze[9][9];
int step[9][9];
bool vis[9][9][7];
int t,n,m;
queue<node> que;
int bfs()
{
    while(que.size())
        que.pop();
    MEM(vis,0),MEM(step,0);
    node p;
    p.x = sx,p.y = sy,p.time = 6;
    que.push(p);
    vis[p.x][p.y][p.time] = true;
    step[p.x][p.y] = 0;
    while(que.size()){
        node q = que.front();
        que.pop();
        if(q.x == ex && q.y == ey && q.time > 0)
            return step[q.x][q.y];
        for(int i = 0;i < 4;i++){
            node r;
            r.x = q.x + dir[i][0];
            r.y = q.y + dir[i][1];
            r.time = q.time - 1;
            if(1 <= r.x && r.x <= n && 1 <= r.y && r.y <= m && !vis[r.x][r.y][r.time] && maze[r.x][r.y]){
                vis[r.x][r.y][r.time] = true;
                step[r.x][r.y] = step[q.x][q.y] + 1;
                if(maze[r.x][r.y] == 4){
                    if(r.time > 0)
                        r.time = 6;
                    vis[r.x][r.y][r.time] = true;
                }
                que.push(r);
            }
        }
    }
    return -1;
}
int main()
{
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= m;j++){
                scanf("%d",&maze[i][j]);
            }
        }
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= m;j++){
                if(maze[i][j] == 2)
                    sx = i,sy = j;
                if(maze[i][j] == 3)
                    ex = i,ey = j;
            }
        }
        printf("%d\n",bfs());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值