1038 Recover the Smallest Number java

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.List;

public class Main {
    /**
     * 最后一组数据超时
     * */
    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] eachStrings = br.readLine().split("\\s+");
        List<String> stirngList = new ArrayList<>();
        for (int i=1; i<eachStrings.length; ++i) {
            stirngList.add(eachStrings[i]);
        }
        Collections.sort(stirngList, new MyComparatorString());
        StringBuilder resultString = new StringBuilder();
        for (int i=0; i<stirngList.size(); ++i) {
            resultString.append(stirngList.get(i));
        }
        int len = resultString.length(), k = -1;
        for (int i=0; i<len; ++i) {
            char ch = resultString.charAt(i);
            if (ch=='0') {
                k = i;
            } else {
                break;
            }
        }
        if (k!=-1) {
            resultString.replace(0, k+1,"");
        }
        if (resultString.length()==0) {
            System.out.println("0");
        } else {
            System.out.println(resultString);
        }
    }
}
class MyComparatorString implements Comparator<String> {

    @Override
    public int compare(String o1, String o2) {
        return (o1+o2).compareTo(o2+o1);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值