1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10
​4
​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

//
//  main.cpp
//  1038 Recover the Smallest Number
//
//  Created by 月文 陈  on 2021/3/2.
//

#include <iostream>
#include<string>
#include<vector>
#include <algorithm>
using namespace std;
bool cmp(string s1,string s2){
    return ((s1+s2)<(s2+s1))>0?true:false;
}

int main(int argc, const char * argv[]) {
    int N;
    cin>>N;
    vector<string> numbers;
    for(int i=0;i<N;i++)
    {   string str;
        cin>>str;
        numbers.push_back(str);
    }
    sort(numbers.begin(), numbers.end(),cmp);
    string result="";
    for(int i=0;i<numbers.size();i++)
    result+=numbers[i];
    while(result[0]=='0'){
        result.erase(result.begin());
    }
    
    if(result.size()==0) cout<<0<<endl;
    else cout<<result<<endl;
    
}


开始的做法:

将所有的数按字典顺序排序,对于除了位数前缀完全一样的数,采用将较短的数补充首位数字的方法;
测试点2是输入全为0
测试点5是补充后跟没补充一模一样的数,看别人是把长的放前面。如 :
23 232 23232 23223
21 212 21212 21221
虽然这样能AC,但是似乎并不对,正确的做法应该是比较第一个数和第二个数,比如:34 343 3<4,所以长的放前面 32 323 3>2 所以短的放前面

void supplement(string &s1,string &s2){
    if(s1.size()>s2.size()){
        char addChar=s2[0];
        for(int i=0;i<s1.size()-s2.size();i++){
            s2+=addChar;
        }
    }else{
        char addChar=s1[0];
        for(int i=0;i<s2.size()-s1.size();i++){
            s1+=addChar;
        }
    }
}
bool cmp(string s1,string s2){
    string s1Cpoy=s1;
    string s2Copy=s2;
    if(s1.size()!=s2.size()){
        supplement(s1Cpoy, s2Copy);
    }
    if(s1Cpoy==s2Copy) return s1[1]>s1[0]?true:false;
    else return s1Cpoy<s2Copy>0?true:false;
}
//
//  main.cpp
//  1038 Recover the Smallest Number
//
//  Created by 月文 陈  on 2021/3/2.
//

#include <iostream>
#include<string>
#include<vector>
#include <algorithm>
using namespace std;
string result="";
void supplement(string &s1,string &s2){
    if(s1.size()>s2.size()){
        char addChar=s2[0];
        for(int i=0;i<s1.size()-s2.size();i++){
            s2+=addChar;
        }
    }else{
        char addChar=s1[0];
        for(int i=0;i<s2.size()-s1.size();i++){
            s1+=addChar;
        }
    }
}
bool cmp(string s1,string s2){
    string s1Cpoy=s1;
    string s2Copy=s2;
    if(s1.size()!=s2.size()){
        supplement(s1Cpoy, s2Copy);
    }
    if(s1Cpoy==s2Copy) return s1[1]>s1[0]?true:false;
    else return s1Cpoy<s2Copy>0?true:false;
}
//3443443 3443344  和 3423423 3423342
void PrintF(string StringPrint) {
    result+=StringPrint;
}
int main(int argc, const char * argv[]) {
    int N;
    cin>>N;
    vector<string> numbers;
    for(int i=0;i<N;i++)
    {   string str;
        cin>>str;
        numbers.push_back(str);
    }
    


    sort(numbers.begin(), numbers.end(),cmp);
    for_each(numbers.begin(), numbers.end(), PrintF);
    string sum="";
    
    int goOn=true;
    for(int i=0;i<result.size();i++){
        if(result[i]=='0'&&goOn) continue;
        else {
            goOn=false;
            sum+=result[i];
        }
    }
    
    if(sum.size()==0) cout<<0<<endl;
    else cout<<sum<<endl;
    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值