Trees on the level

                                                  Trees on the level

原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=1622

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

输入一个二叉树,按从上到下、从左到右的顺序,输出各个结点的值。
每个结点,按照从根结点到它的移动序列给出数据,L表示左,R表示右。
在输入的数据中,每个结点的左括号和右括号之间没有空格,相邻结点之间用一个空格隔开。
每棵树的输入用一对空括号()结束(这对括号本身不代表一个结点)。
如果从根到某个结点的路径上,有结点没有在输入中给出,或者给出超过一次,输出-1。


#include<stdio.h>
#include<string.h>
#include<map>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;

struct node//构建结构体
{
    int x,y;
    string s;
} book[1010];

bool cmp(node a,node b)//自定义cmp排序函数
{
    if(a.y==b.y)
    {
        return a.s<b.s;
    }
    return a.y<b.y;
}

int main()
{
    int n=0,flag=0;
    string str;
    map<string,int>v;//使用map容器来存储
    while(cin>>str)
    {
        int i,num[500];
        if(str=="()")//()代表一棵树完成了输入
        {
            sort(book,book+n,cmp);
            if(flag||book[0].y!=0)
            {
                printf("not complete\n");
            }
            else
            {

                for(i=0; i<n; i++)
                {
                    if(book[i].y>0)
                    {
                        string s;
                        int l=book[i].s.size();
                        for(int j=0; j<l-1; j++)
                        {
                            s+=book[i].s[j];
                        }
                        if(v[s]!=1)
                        {
                            flag=1;//若为1则不符合
                            break;
                        }

                    }
                    num[i]=book[i].x;
                }
                if(flag)
                {
                    printf("not complete\n");
                }
                else
                {
                    for(i=0; i<n; i++)
                    {
                        if(i<n-1)
                            printf("%d ",num[i]);
                        else
                            printf("%d\n",num[i]);
                    }
                }
            }
            n=flag=0;
            v.clear();
            continue;
        }
        int x=0,l=str.size();
        for(i=1; i<l; i++)
        {
            if(str[i]==',')
                break;
            x=x*10+str[i]-'0';//得出字符串长度
        }
        book[n].x=x;//存储字符串长度
        x=0;
        book[n].s.clear();
        for(i=i+1; i<l; i++)
        {
            if(str[i]==')')
            {
                break;
            }
            x++;
            book[n].s+=str[i];
        }
        v[book[n].s]++;
        if(v[book[n].s]>=2)
        {
            flag=1;
        }
        book[n].y=x;
        n++;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值