算法学习递归-----题目: 7-1 根据后序和中序遍历输出先序遍历 (25 分)

7-1 根据后序和中序遍历输出先序遍历 (25 分)

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:
在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
Preorder: 4 1 3 2 6 5 7

#include <iostream>
#include <bits/stdc++.h>
#include <algorithm>
#include <string>
using namespace std;

int in[35],post[35];
typedef struct BiNode{
    int data;
    struct BiNode *lchild;
    struct BiNode *rchild;
}BiNode,*BiTree;

BiTree Build(int *in,int *post,int n)/*第一个参数是中序遍历起始位置,第二个是后序遍历起始位置,n为长度*/
{
    if(n<=0)
        return NULL;
    int *p=in;
    while(p)/*找根节点在中序遍历中的位置*/
    {
        if(*p==*(post+n-1))
            break;
        p++;
    }
    BiTree T =new BiNode;
    T->data=*p;
    int len=p-in;
    T->lchild=Build(in,post,len);
    T->rchild=Build(p+1,post+len,n-len-1);
    return T;
}

void Preorder(BiTree t)
{
    if(t)
    {
        cout<<" "<<t->data;
        Preorder(t->lchild);
        Preorder(t->rchild);
    }
    return;
}

int main()
{
    int n;
    cin>>n;
    BiTree t;
    for(int i=0;i<n;i++)
    {
        cin>>post[i];
    }
    for(int j=0;j<n;j++)
    {
        cin>>in[j];
    }
    t=Build(in,post,n);
    cout<<"Preorder:";
    Preorder(t);
    return 0;
}

也参考了其他博主的方法,仅供学习使用。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值