yii2 composer安装出错

composer 安装yiisoft/yii2出现一堆错误:如下

yiisoft/yii2 2.0.13.2 requires 
bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable 
| 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> 
no matching package found

这种错误可以使用如下命令解决:

composer global require “fxp/composer-asset-plugin:^1.2.0”

有些时候还要在composer.json中加入


"extra": {

    "asset-installer-paths": {

        "npm-asset-library": "vendor/npm",

        "bower-asset-library": "vendor/bower"

    }

}

然后有可能还会出现警告:

The "extra.asset-installer-paths" option is deprecated, 
use the "config.fxp-asset.installer-paths" option

此时就按照提示的将在extra的改在config中就行,如下


"config" : {

   "fxp-asset.installer-paths" : {

      "npm-asset-library" : "vendor/npm",

      "bower-asset-library" : "vendor/bower"

   }

}

还有一件事!可能提示你没存github token,提示

GitHub API limit (60 calls/hr) is exhausted, 
could not fetch https://api.github.com/repos/jquery/jquery-dist. 
Create a GitHub OAuth token to go over the API rate limit. 

这个可以忽略,但是你会发现可能需要安装的特别多,所以,还是直接设置一个吧

到github上 https://github.com/settings/tokens/new 登录账号,选择需要的权限,点击生成token即可

这里还可能出现vendor/bower/jquery/dist文件不存在

在vendor目录中存在bower-asset目录而不存在bower目录

  • 可以修改 入口文件加上配置
"aliases" => [
       "@bower" => "@vendor/bower-asset",
       "@npm" => "@vendor/npm-asset"
]
  • 另外一种就是直接运行
composer install -vvv
发布了24 篇原创文章 · 获赞 2 · 访问量 8038
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览